2

I'm running into an issue when setting up a Windows 2012 R2 RDS Farm. I mistakenly set up my High Availability Connection Broker's DNS round robin name to something that didn't match my cert. I found a way to easily change the DNS name here: https://technet.microsoft.com/en-us/library/jj215484.aspx using the PowerShell cmdlet Set-RDClientAccessName. When searching online I can see that a lot of people are having success using that cmdlet, but I am not. Here's the error I'm receiving:

PS C:\Users\root> Set-RDClientAccessName -ConnectionBroker "FMS-RDSBROKER01.blah.local" -ClientAccessName rds.bar.com

Set-RDClientAccessName : The RD Connection Broker server is not available. Verify that you can connect to the RD Connection Broker server. At line:1 char:1 + Set-RDClientAccessName -ConnectionBroker "FMS-RDSBROKER01.foo.com" -Clien ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Set-RDClientAccessName

I'm not sure why this keeps failing. This command is being run from the Connection Broker itself by by a domain admin (the same one who has been setting up the RDS farm from ground zero). I also cannot suvessfully run that command from the other Connection Broker, nor any other server in the farm. I'm also certain that I have the module installed to enable that cmdlet:

PS C:\Users\root> Get-Module -Name RemoteDesktop -ListAvailable

Directory: C:\Windows\system32\WindowsPowerShell\v1.0\Modules

ModuleType Version Name ExportedCommands ---------- ------- ---- ---------------- Manifest 2.0.0.0 RemoteDesktop {Get-RDCertificate, Set-RDCertificate, >New-RDCertificate, ...

If anyone has any troubleshooting steps I'd appreciate it. I am worried that the dash in the hostname is a problem, but I tried single and double quotes to attempt to rule that out. I'm also not a Powershell buff so I'm not certain what steps are advised after that error.

1

I found the solution, and it's painfully aggravating that I missed this- I wasn't running Powershell as an administrator. Correcting that oversight allowed me to fun the command successfully.

Thank you to everyone who viewed this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.