1

I have a new Dell PowerEdge T320 server with 1 SSD non-RAID and 3 HDDs in RAID 5 all on one Perc H310 controller. RAM is 48 GB and I have Windows Server 2012 R2 Data Center installed on the SSD.

I initially was attempting to create a VHDX on the RAID. The VHDX to create was of fixed size (over a 100 GB) and attempts to do that through the GUI and PowerShell both failed with I/O errors and crashes.

I then, in an attempt to find the problem, tried a simple copy and paste of a 50GB VHDX from the SSD to the RAID. That also caused a crash. I tried further to copy a large file (120 GB) created using fsutil from the SSD to RAID, again fail.

I read somewhere that there was a problem with large files and caching when using the default copy command, so I got a suggested tool "terracopy" which has the option (default) to have system write cache disabled. That went on copying for some time before I decided to stop it since it seemed to be working.

My main need is to create a large VHDX, does anyone have a clue what is going on?

Edit: Additional details:

  • Ran Diagnostics, did not yeild anything useful.
  • Dell replaced the RAID controller, no change.
  • Installed Windows 8 to test the copy and paste, it went on copying for a relatively long time before I stopped it since it looked like there would be no crash.
  • Booted from Linux Puppy USB, did a copy paste of a 120GB file from the SSD to the RAID, no issues.
  • 1
    sounds like a hardware problem to me. It should be no problem copying file >100GB with normal OS copy commands. It seems the SSD is always involved, try to a copy operation without it. – Peter Hahndorf Feb 4 '15 at 8:01
  • @PeterHahndorf I tried coping from an external drive, still failed. – 3m3sd1 Feb 4 '15 at 8:11
  • 1
    Yeah. Change from "I have a server" to "I have a broken server". Smells like some hardware is off. ECC ram? If not - run a memory test. – TomTom Feb 4 '15 at 9:29
  • is the drive encrypted i.e. with bitlocker ? if so the destination needs to be using the same bitlocker encryption. – JJJJNR Feb 4 '15 at 10:41
  • @JJJJNR No encryption whatsoever, fresh windows installation. – 3m3sd1 Feb 4 '15 at 11:19
1

This looks like the old Server 2008 issue they eventually fixed with release of the Dynamic Cache Service addon: http://www.microsoft.com/en-us/download/details.aspx?id=9258

In a nutshell reads and writes are cached to memory which eventually fills it and makes the server unresponsive.

I couldn't find anything regarding server 2012 and this, but the behaviour looks the same. In the past I've seen Robocopy cause the same issue.

The XCOPY /J unbuffered copy bypasses this issue.

0

Dell replace the controller without anything to say that it was the issue? Weird. Tell them the problem still exists and to replace everything. Proc/board/ram until fixed.

  • Could it be a Windows problem? I successfully managed to copy the file using TeraCopy. Also, another version of Windows (Windows 8) did not seem to cause an issue. – 3m3sd1 Feb 4 '15 at 23:53
  • Can't see it being a windows issue, I copy large files a lot and have never come across this issue, you could try running process mon at the time of the copy and see where the process fails. – JJJJNR Feb 5 '15 at 0:04
0

Had a similar issue with a Dell controller. When the RAID5 virtual disk on the controller is set to write-through, the copy performance issue exists. When the virtual disk is switched to write-back, the problem disappears.

You could also try using XCOPY with the /J parameter to use unbuffered IO. This will avoid the file system cache overhead and prevent the file system cache from being effectively flushed by the large file data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.