-6

I am running two docker containers one is for hadoop basic services and other is for flume. Services are running successfully. I linked two containers env variables are automatically set by docker successfully.

1.2.3.4    7ab4ffb30dc0
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
127.0.0.1       localhost
::1     localhost ip6-localhost ip6-loopback

fe00::0 ip6-localnet

This is My /etc/hosts file for hadoop. When i run

hadoop fs -ls /
hadoop fs -ls hdfs://127.0.0.1:8020/

Works fine. But if i run

hostname

it returns 7ab4ffb30dc0

So i tried

hadoop fs -ls hdfs://1.2.3.4:8020/

it says Call From 7ab4ffb30dc0/1.2.3.4 to 7ab4ffb30dc0:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused

Any suggestions?

Hello, I learned from that site

These are the directions which i learened to tackle serverfault problem

  telnet localhost

says connection refused. it tried to connect to 127.0.0.1 and 0::

  telnet feorar.org

works so telent daemon is running

  telnet localhost 44444

says Trying ::1... Connected to localhost. Escape character is '^]'. Connection closed by foreign host. but

  netstat -tna

says service is listening at :::44444

  telnet localhost 25

works. there is an entry for port 25.

I don't understand what's the difference between :::44444 and ::1:25 under localhost of netstat -tna 's output. Any help?

1
  • 3
    This question is being voted for closure because the author does not show a level of technical understanding or appropriate due diligence in researching the topic that the community judges as being a minimum barrier to participate.
    – Wesley
    Feb 6, 2015 at 7:49

1 Answer 1

6

My suggestion is to read the information provided.

java.net.ConnectException: Connection refused;

This generally means nothing is listening on the specified IP:Port.

Note also this information is provided

http://wiki.apache.org/hadoop/ConnectionRefused

and it's first line

You get a ConnectionRefused Exception when there is a machine at the address specified, but there is no program listening on the specific TCP port the client is using -and there is no firewall in the way silently dropping TCP connection requests.

There is more information in the helpful link too, you should read it.

Please be bothered to read the information provided before wasting the internet's time.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.