2

In Debian Linux stable version, there is always lag between current and stable version. Thus one of packages Clamav is very noisy about this, and log files are full of:

WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.98.5 Recommended version: 0.98.6
DON'T PANIC! Read http://www.clamav.net/support/faq

I am using monitoring package Logwatch, and it sends all this to my email. Is there a way to stop freshclam from writting this warning to log or skip it from Logwatch?

  • I have not tried it, so I can't say how well it works, but you can strip output from the logwatch emails by placing regular expressions in /etc/logwatch/conf/ignore.conf. – Roger Sherman Feb 4 '15 at 18:48
0

This is workaround for Logwatch.

After digging into programs, I found that ni Debian by default there is no Logwatch configuration file, which should be placed in /etc/logwatch/conf and it uses default configuration file from: /usr/share/logwatch/default.conf/logwatch.conf

Thus ONE workaround is to make own configuration for Logwatch and SKIP clam-auth module from report. This can be done in such steps:

cp /usr/share/logwatch/default.conf/logwatch.conf /etc/logwatch/conf

Edit /etc/logwatch/conf/logwatch.conf with favorite editor, find section in the file:

# The 'Service' option expects either the name of a filter
# (in /usr/share/logwatch/scripts/services/*) or 'All'.
# The default service(s) to report on.  This should be left as All for
# most people.
Service = All

and ADD such line:

Service = "-clam-update"

This will skip freshclam log file from reports. This lead to other danger, that if updates start failing for some reason, you will not be notified about this.

  • If someone could find how to disable freshclam warnings in log, answers are also welcome! – Arunas Bartisius Feb 10 '15 at 4:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.