0

I'm having a major issue with some music software, I was hoping if I quickly explained what I have done, some GPO guru might be able to spot where I have went wrong?

Server 2012
Client OS - XP SP3 
Music Software - Cubase 5

Ok, so the students need to be able to change the buffer size on some external soundcards (called an Mbox) in conjunction with Cubase 5. However, they no longer have access to the registry so are unable to change a specific setting. I used SysMon from SysInternals and have found the keys, set them to the lowest setting, exported them, added them to the DC and setup the following policy:

Computer Configuration > Policies > Windows Settings > Registry

MACHINE\Software\Digidesgin\Digiasio

Right click object/reg key > Properties

Set to "Replace existing permission on all subkeys with inheritable permissions"

Edit security > gave users full control

I then logged in as a student and checked that the computer policy was copied down using psexec:

psexec.exe \\computername -u domain\myadminaccount gpresult.exe /scope computer /v

But it seems to reset the key to the highest setting for the students, even though I set it to something else (for example, they key i exported is set to 128 milliseconds, but its reset to 1024 milliseconds when a student logs in) They are still unable to change this setting.

Can anybody suggest what I can try next, i used StackExchange in the past for other problems I've had (php etc)...hope Im in the right section.

0

Well I have found a solution, not using a GPO but a program called CPAU. It allows you to run programs with more elevated rights.

http://www.joeware.net/freetools/tools/cpau/

First step is to create an encoded job file, to do this, open a cmd prompt in the same location as the program.exe:

cpau -u domain\username -p accountpassword -ex "program.exe" -enc -file program.job

This creates the job file, now open a text file in the same location again and enter:

cpau -dec -file program.job –lwp

Save this as "nameoftheprogram.cmd" and apply any security permissions (ie, everyone)

You should have the cpau.exe, program.job and program.cmd all in the same location as the original program.exe. Change the icon to the .cmd file and move the shortcut a location where they have access.

Sorted!

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.