0

I am using IIS 8.5 on Windows Server 2012.
I have installed and configured IIS "Management Service".

When running "Connect To Site" locally and attempting to connect to a site on the server using "localhost" or 127.0.0.1, it works fine...

When running "Connect To Site" remotely and attempting to connect to a site on the server using its IP Address, it does not work.

I get this error:

Could not connect to the specific computer.

Details: The remote server returned an error: (503) Server Unavailable.

I tried changing the Certificate, and from the remote machine it acknowledged that the cert changed:

This certificate was issued to a different server.

Security certificate problems may indicate....

This means to me that the actual Web Management Service is somehow being blocked. This server is running on AWS, and I have a Security Group that allows traffic on the Web Management port 8172 from my machine.

The Windows Firewall has Inbound Rules allowing traffic through 8172, but the firewall appears to be off.

This was working before, but I reinstalled the Web Management Service and it did not work after that.

I have searched all over and cannot find anything like this particular issue. I have looked at the log files for the Web Management Service (C:\inetpub\logs\wmsvc\W3SVC1) and cannot see any entries for when the 503 error occurs. I do have "Enable failed request tracing" checked, but it does not appear to make a difference.

If anyone has any ideas how I could debug this further and/or what might be the issue I would greatly appreciate it.

1

I struggled a long time with the same thing. What worked for me was: On the machine where you installed he IIS role:

  1. open a cmd window with elevated privileges (run as administrator)
  2. Type netsh
  3. Type http
  4. Type show sslcert
  5. Use the command delete sslcert ipport=ip-addr:8172 and remove all certificates having to do with port 8172
  6. Uninstall the IIS management service feature via "remove roles or features"
  7. Re-install the feature
  8. Open regedit and find the key HKLM\SOFTWARE\Microsoft\WebManagement\Server\IPAddress
  9. Change te IP address parameter from * tot the actual IP address the management service is listening on
  10. Open the IIS management console. Click on the server node, select the feature management service.
  11. Enable remote management and use the actual IP address (not the "all unsassigned" setting

After all that, it worked for me. The re-installing of the management service left some settings behind that interferde with the proper functioning of the feature, or so it seems. Hopefully this will work for you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.