8

I have a very strange issue. I'm setting up an RDS server in azure for a proof of concept. I've found that if I use the web access using the external URL provided by azure (xxxx.cloudapp.net/RDWeb), I can log in fine, even get the little popup in the taskbar to say i'm connected, however the page shows no remoteapps available - as if none had been published.

If I modify my hosts file to treat the external IP address as having the internal dns name (xxx.domain.local etc), and use that to access RDWeb, it works perfectly. I can access the remoteapp catalog, choose an app and run it with no problems at all.

I've tried everything I can think of, including setting up an rds gateway which wasn't installed before, but nothing makes any difference. Does anyone have any insight?

1

I had this issue, it's all down to names and certificates. You need to ensure that:

  • All servers are configured to present your External DNS name, RD Web Server, Session Hosts, brokers and Gateway (if you have one)
  • Servers need to be able to respond to that External name on the internal network, so you will need to setup a second DNS zone on your Internal network, with the external name and correct IP's for all servers
  • Ensure that all servers have a valid certificate for the external domain. You will likely need a wildcard for this as you need all servers presented as servername.external.domain
0

A year ago I came across a similar problem where the certificate and name of our server was causing an issue publishing our company's applications.

Seeing as the change to your local host file fixed the issue, you might want to have your RDP server present the its name as something other than xxxx.domain.local.

Try using the script located here.

  • Thanks for the attempt, but i'd already tried that one. – Frater Feb 15 '15 at 22:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.