0

So I am having issues with connecting to my web server via eth1.

ifconfig

eth0  Link encap:Ethernet  HWaddr 00:50:c2:27:bf:6e
      inet addr:10.8.105.8  Bcast:0.0.0.0  Mask:255.255.0.0
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:276 errors:0 dropped:1 overruns:0 frame:0
      TX packets:73 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:39584 (39.5 KB)  TX bytes:17228 (17.2 KB)

eth1  Link encap:Ethernet  HWaddr 00:50:c2:27:bf:6f
      inet addr:169.254.100.100  Bcast:0.0.0.0  Mask:255.255.0.0
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:3892 errors:0 dropped:1 overruns:0 frame:0
      TX packets:739 errors:0 dropped:37 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:399308 (399.3 KB)  TX bytes:69067 (69.0 KB)
      Interrupt:155 Base address:0x6000

lo    Link encap:Local Loopback
      inet addr:127.0.0.1  Mask:255.0.0.0
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:30 errors:0 dropped:0 overruns:0 frame:0
      TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:2196 (2.1 KB)  TX bytes:2196 (2.1 KB)

/etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 10.8.105.8
netmask 255.255.0.0
gateway 10.8.1.1

auto eth1
iface eth1 inet static
address 169.254.100.100
netmask 255.255.0.0

When connected to eth0 I can access my web server.

When using eth1 and connecting directly from my computer via ethernet cable I can not connect to the web server. On fresh reboot of the server I can ping the server IP and get responses from either side. However as soon as I try to connect to the IP via the browser or attempt to Putty into the server it breaks. I can not connect at all and then if I attempt to ping the server again it will say either Request timed out or Destination host unreachable

I am not up to date on my networking and am not sure of how to handle this. I have scoured the internet for several hours with no success.

Does anyone know how to fix this issue?

Update 1:

route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.8.1.1        0.0.0.0         UG    100    0        0 eth0
10.8.0.0        0.0.0.0         255.255.0.0     U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0

I am using apache 2.2.20

No logs were being posted in the /var/log/apache2/access.log when I was pinging or trying to connect to the web server via browser.

  • could you post the output of 'ip route' (or equivalent depending on your distribution), the webserver (apache? nginx?) you are using, and the pertinent lines of log files (the one showing the webserver or firewall accept your connection and then reject them)? – Manu H Feb 6 '15 at 16:23
  • @ManuH Added info under Update 1 – Keith Feb 6 '15 at 17:02
  • 1
    The last line of the route table is weird. You should delete this route. If there is no log, I suspect your apache just shutdown itself. I still fail to see wht you do. what happen on fresh reboot if you try to connect via eth1 only? – Manu H Feb 7 '15 at 10:29
  • When only connecting to eth1, I am able to ping the device. I ran wireshark on client side and it shows that when I try to load the webserver that it gets a request for port 80 and the server sends and ack but it only does this twice before, which I am assuming, disconnecting. – Keith Feb 9 '15 at 12:47
0

Check the routes on your client machine, and consider doing packet captures to narrow down the troubled network flow.

  • Checking routes is one thing I am not familiar with. I assume wireshark would be good for packet capture? If so would I need it on client or server side? – Keith Feb 6 '15 at 15:48
  • On Linux you can display the routing table with 'sudo route -n' on windows it's 'route print'. Wireshark is a perfect tool to use, you'll want to try capturing on both sides to see what traffic IS making it across. I assume your connection is [Client] <---> [Host] via a directly connected Ethernet cable, or are you plugged into a switch? – Noobixide Feb 6 '15 at 15:51
  • 1
    Thanks for the commands for routing, I will have to do some research to see if they are right and ok. I am not going through a switch. Connected directly and I change the IP address of my client to 169.254.100.110 with a netmask of 255.255.0.0, so should work fine – Keith Feb 6 '15 at 15:56
  • I have to agree that the last line of that routing table looks strange. – Noobixide Feb 7 '15 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.