0

I need to manage the number of outgoing concurrent SMTP connections - other mail servers are complaining that I have more than 50 concurrent connections and throttling my outgoing mail.

I googled and found the "queue_run_max" option, which sounded like what I need. From my reading it is supposed to go in exim4.conf, but I don't one of those, perhaps because I'm using a split configuration file. Anyways, most of my options are in update-exim4.conf.conf so I added it to this file. I then restarted exim4 and got this message:

root@ds6419:/etc/exim4# /etc/init.d/exim4 restart
[....] Stopping MTA for restart:/usr/sbin/update-exim4.conf: 36: /etc/exim4/update-exim4.conf.conf: queue_run_max: not found

I therefore removed the option and got exim4 running again.

The only other queue configuration parameters I could find were in /etc/default/exim4 and these I have included below:

# /etc/default/exim4
EX4DEF_VERSION=''
# 'combined' -   one daemon running queue and listening on SMTP port
# 'no'       -   no daemon running the queue
# 'separate' -   two separate daemons
# 'ppp'      -   only run queue with /etc/ppp/ip-up.d/exim4.
# 'nodaemon' - no daemon is started at all.
# 'queueonly' - only a queue running daemon is started, no SMTP listener.
# setting this to 'no' will also disable queueruns from /etc/ppp/ip-up.d/exim4
QUEUERUNNER='combined'
# how often should we run the queue
QUEUEINTERVAL='5m'
# options common to quez-runner and listening daemon
COMMONOPTIONS=''
# more options for the daemon/process running the queue (applies to the one
# started in /etc/ppp/ip-up.d/exim4, too.
QUEUERUNNEROPTIONS=''
# special flags given to exim directly after the -q. See exim(8)
QFLAGS=''
# Options for the SMTP listener daemon. By default, it is listening on
# port 25 only. To listen on more ports, it is recommended to use
# -oX 25:587:10025 -oP /var/run/exim4/exim.pid
SMTPLISTENEROPTIONS='-oX 465:25 -oP /var/run/exim4/exim.pid'

My exim4 version is:

root@ds6419:/etc/exim4# exim4 --version
Exim version 4.80 #3 built 24-Jul-2014 03:28:10
Copyright (c) University of Cambridge, 1995 - 2012
(c) The Exim Maintainers and contributors in ACKNOWLEDGMENTS file, 2007 - 2012
Berkeley DB: Berkeley DB 5.1.29: (October 25, 2011)
Support for: crypteq iconv() IPv6 GnuTLS move_frozen_messages DKIM
Lookups (built-in): lsearch wildlsearch nwildlsearch iplsearch cdb dbm dbmjz dbmnz dnsdb dsearch nis nis0 passwd
Authenticators: cram_md5 plaintext
Routers: accept dnslookup ipliteral manualroute queryprogram redirect
Transports: appendfile/maildir/mailstore autoreply lmtp pipe smtp
Fixed never_users: 0
Size of off_t: 8
Configuration file is /var/lib/exim4/config.autogenerated

Can anybody help please? Does the queue_run_max go somewhere else? Or is there a different option for my version of exim4?

  • It looks like this option should be somewhere higher in your config file, try it to put after "domainlist". – Hikaru Feb 11 '15 at 17:22
0

You are using a Debian exim4 split config (you're likely using a Debian or Ubuntu based distro). When referring to Debian based systems, we always specifically say exim4 to indicate that it's a non-default exim configuration.

The file you are editing is a template configuration file, not the actual file that Debian's exim4 reads. The Debian init scripts read the contents of that file and several template files in /etc/exim4/, and assembles a standard exim4.conf file from them. You'll want to read at http://pkg-exim4.alioth.debian.org/README/README.Debian.html for more detailed information.

Ultimately the answer is "if Debian's configuration has exposed that particular setting to your control", which is a bit uncertain. Others here may know the Debian Exim4 configuration controls a lot better. There is also an Exim4 specific mailing list that you can likely get the authoritative answers at http://lists.alioth.debian.org/mailman/listinfo/pkg-exim4-users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.