4

Can anyone tell me what's postfix telling me with this error?

Feb  9 13:08:59 hostname postfix/postfix-script[23077]: starting the Postfix mail system
Feb  9 13:08:59 hostname postfix/master[23079]: daemon started -- version 2.10.1, configuration /etc/postfix
Feb  9 13:11:32 hostname postfix/smtpd[23180]: warning: connect #1 to subsystem private/proxymap: Connection refused
Feb  9 13:11:42 hostname postfix/smtpd[23180]: warning: connect #2 to subsystem private/proxymap: Connection refused
Feb  9 13:11:52 hostname postfix/smtpd[23180]: warning: connect #3 to subsystem private/proxymap: Connection refused
Feb  9 13:12:02 hostname postfix/smtpd[23180]: warning: connect #4 to subsystem private/proxymap: Connection refused
Feb  9 13:12:12 hostname postfix/smtpd[23180]: warning: connect #5 to subsystem private/proxymap: Connection refused
Feb  9 13:12:22 hostname postfix/smtpd[23180]: warning: connect #6 to subsystem private/proxymap: Connection refused
Feb  9 13:12:25 hostname clamd[1636]: SelfCheck: Database status OK.
Feb  9 13:12:32 hostname postfix/smtpd[23180]: warning: connect #7 to subsystem private/proxymap: Connection refused
Feb  9 13:12:42 hostname postfix/smtpd[23180]: warning: connect #8 to subsystem private/proxymap: Connection refused
Feb  9 13:12:52 hostname postfix/smtpd[23180]: warning: connect #9 to subsystem private/proxymap: Connection refused
Feb  9 13:13:02 hostname postfix/smtpd[23180]: warning: connect #10 to subsystem private/proxymap: Connection refused
Feb  9 13:13:12 hostname postfix/smtpd[23180]: fatal: connect #11 to subsystem private/proxymap: Connection refused
Feb  9 13:13:13 hostname postfix/master[23079]: warning: process /usr/libexec/postfix/smtpd pid 23180 exit status 1
Feb  9 13:13:13 hostname postfix/master[23079]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

it happens when create a new virtual user with my postfixadmin. It created ok, but postfixadmin keep loadding without answer till I cancel and then realized that the user is created. postfix check doesn't give me any output and postconf -n :

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5
home_mailbox = Maildir/
html_directory = no
inet_interfaces = localhost
inet_protocols = all
local_recipient_maps = $virtual_mailbox_maps
local_transport = virtual
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
mydomain = example.com
myhostname = mail.example.com
mynetworks = 127.0.0.0/8
mynetworks_style = host
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.10.1/README_FILES
relay_domains = $mydestination
sample_directory = /usr/share/doc/postfix-2.10.1/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_relay_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $mydomain
smtpd_sasl_path = /var/run/dovecot/auth-client
smtpd_sasl_security_options = noanonymous
smtpd_sasl_tls_security_options = $smtpd_sasl_security_options
smtpd_sasl_type = dovecot
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/ssl/private/server.crt
smtpd_tls_key_file = /etc/ssl/private/server.key
smtpd_tls_loglevel = 1
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 550
virtual_alias_maps = proxy:mysql:/etc/postfix/virtual_alias_maps.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/virtual_mailbox_domains.cf
virtual_mailbox_limit = 512000000
virtual_mailbox_maps = proxy:mysql:/etc/postfix/virtual_mailbox_maps.cf
virtual_minimum_uid = 5000
virtual_transport = virtual
virtual_uid_maps = static:5000

this is postconf -M

dovecot    unix  -       n       n       -       -       pipe flags=DROhu user=vmail:vmail argv=/usr/libexec/dovecot/deliver -f ${sender} -d ${user}@${nexthop}
amavis     unix  -       -       -       -       2       smtp 
-o smtp_data_done_timeout=1200 
-o smtp_send_xforward_command=yes
127.0.0.1:10025 inet n   -       -       -       -       smtpd 
-o content_filter= -o local_recipient_maps= 
-o relay_recipient_maps= 
-o smtpd_restriction_classes= -o smtpd_client_restrictions= 
-o smtpd_helo_restrictions= 
-o smtpd_sender_restrictions= -o smtpd_recipient_restrictions=permit_mynetworks,reject 
-o mynetworks=127.0.0.0/8 -o strict_rfc821_envelopes=yes 
-o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
smtp       inet  n       -       n       -       -       smtpd
submission inet  n       -       -       -       -       smtpd 
-o syslog_name=postfix/submission 
-o smtpd_tls_security_level=encrypt 
-o smtpd_sasl_auth_enable=yes 
-o smtpd_client_restrictions=permit_sasl_authenticated,reject
proxymap   unix  -       -       n       -       -       proxymap
relay      unix  -       -       n       -       -       smtp
flush      unix  -       -       n       1000?   0       flush
trace      unix  -       -       n       -       0       bounce
verify     unix  -       -       n       -       1       verify

Should I assume it's the same problem as here? postfix/dovecot/mysql not sending/getting emails

I'm also receiving this dovecot error: auth-worker(1560): Error: mysql(localhost): Connect failed to database (postfix_db): Access denied for user 'postfix'@'localhost' (using password: YES) which i realized just now at the time testing imap with telnet and try to log with a already created user with and without domain, could be this related?

  • So, did the answer from postfix/dovecot/mysql not sending/getting emails solve your problem? – masegaloeh Feb 9 '15 at 13:02
  • @masegaloeh I hadn't done an upgrade, I don't know if i should and if would be useful to do that. I have postfix 2.10.1 – MikZuit Feb 9 '15 at 13:10
  • Are you missing whitespaces before all the options with -o in the master.cf? Usually there has be at least one. – sebix Feb 19 '15 at 14:49
  • I'm not missing whitespaces in -o options @sebix , just here . I strongly believe that is a permissions issue , I will answer as soon as I know the answer. – MikZuit Feb 19 '15 at 18:13
2

The output of postconf -M will tell you the valid entry of master.cf. Based of that, looks like you have missing proxymap entry. Put this line on master.cf

proxymap  unix  -       -       n       -       -       proxymap

Proxymap service was needed by postfix because you have set enable proxy option in main.cf. Those configurations were virtual_alias_maps, virtual_mailbox_domains and virtual_mailbox_maps.

  • The errors doesn't seem to be related to this, still having the same log messages. – MikZuit Feb 10 '15 at 9:30
  • DId you restart postfix? Please post the updated output of postconf -n and postconf -M. – masegaloeh Feb 10 '15 at 9:50
  • done (updated), by the time I test to create a new virtual mailbox I restarted dovecot, postfix and apache. Please read the updated part at the end. – MikZuit Feb 10 '15 at 11:11
  • Weird. 1) can you post the output of sudo netstat -an | grep proxymap to verifying? 2) can you connect to mysql with the credential in maps? – masegaloeh Feb 10 '15 at 11:34
2

For a strange reason @masegaloeh 's answer doesn`t work with me instead when I use this, trying to solve another error, it fixed. So ain't going to say this is the right answer but I leave it anyway in case help anyone to solve similar problems.

I Just add this line in my /etc/postfix/master.cf file because I have an smtpd error like this: "subsystem public/cleanup: Connection refused" and voilá , both errors gone.

cleanup   unix  n       -       n       -       0       cleanup 
  • Well, you don't report to us that you also have another error subsystem public/cleanup: Connection refused, you only post the proxymap error log. Anyway, congratulations for solving the problem :) – masegaloeh Feb 20 '15 at 11:28
  • well, you know the rules @masegaloeh first I look for myself and then if I'm not able to solve it , I do ask. This error was for a long time, and the other was new. Thank for everything – MikZuit Feb 23 '15 at 12:41
  • You are welcome :) – masegaloeh Feb 23 '15 at 13:04
1

I had the same "subsystem public/cleanup: Connection refused" problem but when I looked at the /etc/postfix/master.cf file, the mentioned line was already there. So in my case the solution was to simply restart postfix:

service postfix restart

After that, I received all the emails that weren't sent before...and that was a lot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.