0

I'm trying to install php-imap on CentOS 6.6

yum install php-imap

But I'm getting this error:

Error: Package: php-common-5.3.29-4.w5.x86_64 (webtatic)
           Requires: libcurl.so.3()(64bit)
Error: Package: php-imap-5.3.29-4.w5.x86_64 (webtatic)
           Requires: libc-client.so.1()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

If I try to install libcurl by yum install libcurl it says it's already installed

Package libcurl-7.19.7-40.el6_6.4.x86_64 already installed and latest version

I can't figure out what's the problem. Anyone knows how to fix this?

1

You are mixing 3rd party repository (webtatic), and thats why you are having issues.

What you can do is:

yum install php-imap --disablerepo=webtatic

This will install php-imap from official CentOS repositories.

Other thing that seems wrong is "w5" in the release version of a package yum is offering you. It suggests that you added Webtatic for EL5 on CentOS 6.x series. From what I can see, webtatic uses "w6" in package release if its meant for EL6/CentOS6.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.