0

I'm trying to get Cacti, which runs on one VM, to graph the data from another VM. However I'm facing an SNMP error despite my efforts.

The two VMs are running as NAT connection on VMWorkstation.

The I.P. for the cacti host is 192.168.1.33 while the I.P. of the CentOS system I am trying to get into is 192.168.111.130.

I have appended "rocommunity public" to the end of the /etc/snmpd/snmpd.conf file

I ran a test command "snmpwalk -v 1 -c public localhost .1.3.6.1.2.1.1.1.0" and found the query does return a result.

I am unsure what else is there to configure. Selinux and iptables have been turned off but to no avail.

The service has been restarted mutiple times as well.

Any advice will be greatly appreciated.

0

Seems like a NAT traversing issue. Your VMs are in different subnets, so they are communicating through the router. You should take tcpdump and diagnose whether VMs are seeing each other requests/replies.

  • Good point, saw that as a little after i posted this. Drew up two static IP and things seems to be working. Much appreciated! – user4985 Feb 12 '15 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.