-1

I am trying to build Mongodb 3.0.0-rc8 (tried latest nightly too) with ssl support. I found a gist which works for 2.6.7 but when I run it with 3.0.0-rc8 I get that eror

src/mongo/crypto/crypto_tom.cpp:30:2: error: #error This file should not be included if compiling with SSL support

I am building it in docker so the environment should be fairly standard.

Any idea?

1

Remove the file crypto_tom.cpp and try again.

1

So after some try and error (Thanks @wesley that put me on the right path), there is a known bug where if you try to build all the different target despite what you specify if you put the source in the parent folder of where you want to install them. I put my source in /usr/src/mongo and the target is /usr/ So I assume it try to build the non ssl as well as the ssl version. Once I put my source in ~ in worked like a charm. Hope it will help someone else with the same non descriptive error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.