0

I've changed a password for one of my users (using passwd username), and now ProFTPd won't allow that user to log in. Other users can still log in as normal.

I'm running Ubuntu 14.04 LTS

The error I'm getting in /var/log/auth.log is:

pam_unix(proftpd:auth): authentication failure; logname= uid=0 euid=0 tty=/dev/ftpd28150 ruser=webuser rhost=188-39-142-115.static.enta.net  user=webuser

The user (as per /etc/passwd) remains the same as the other FTP users which still work:

webuser:x:1001:1001::/var/www/thewebsite.co.uk:

Is there somewhere else that PAM looks to authenticate the user?

EDIT

My /etc/proftpd doesn't contain a .htaccess, it just contains the following:

blacklist.dat
conf.d
dhparams.pem
ldap.conf
modules.conf
proftpd.conf
sql.conf
tls.conf
virtuals.conf

My proftpd.conf looks like this:

Include /etc/proftpd/modules.conf
UseIPv6                         on
IdentLookups                    off
ServerName                      "Debian"
ServerType                      standalone
DeferWelcome                    off
MultilineRFC2228                on
DefaultServer                   on
ShowSymlinks                    on
TimeoutNoTransfer               600
TimeoutStalled                  600
TimeoutIdle                     1200
DisplayLogin                    welcome.msg
DisplayChdir                    .message true
ListOptions                     "-l"
DenyFilter                      \*.*/
Port                            21
MaxInstances                    30
User                            proftpd
Group                           nogroup
Umask                           022  022
AllowOverwrite                  on
# PersistentPasswd              off
# AuthOrder                     mod_auth_pam.c* mod_auth_unix.c
# UseSendFile                   off
TransferLog /var/log/proftpd/xferlog
SystemLog   /var/log/proftpd/proftpd.log

<IfModule mod_quotatab.c>
QuotaEngine off
</IfModule>

<IfModule mod_ratio.c>
Ratios off
</IfModule>

<IfModule mod_delay.c>
DelayEngine on
</IfModule>

<IfModule mod_ctrls.c>
ControlsEngine        off
ControlsMaxClients    2
ControlsLog           /var/log/proftpd/controls.log
ControlsInterval      5
ControlsSocket        /var/run/proftpd/proftpd.sock
</IfModule>

<IfModule mod_ctrls_admin.c>
AdminControlsEngine off
</IfModule>
  • please provide configuration and more information – c4f4t0r Feb 17 '15 at 15:23
  • It could be that your server is configured to use a .htpasswd file for authentication, look for such a file in /etc/proftpd, these files usually have 600 permissions (rw-------). – Itai Ganot Feb 17 '15 at 15:23
  • Updated my question for both of you guys... – a1phanumeric Feb 17 '15 at 15:33
  • Theres no shell listed in the users passwd entry. I'm not sure if not setting it is valid. – Matthew Ife Feb 17 '15 at 15:37
  • That's not making a difference - other FTP users don't have a shell and they work. It was simply the action of changing the user's password that's caused this issue to arise. – a1phanumeric Feb 17 '15 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.