0

I am using Windows Server 2012 in which i have share internet throw NAT to secondary lan card using Routing and remote service and now the problem is that when my client are browsing through proxy 10.0.0.1:3128 all thing goes in a right manner but they remove this proxy from internet option then they are able to browse the website which are blocked by proxy.

so please tell me how to redirect the client traffic through the Proxy server only.

  • Remove/block the gateway they are using, so proxy is only available route. – jlehtinen Feb 18 '15 at 14:49
  • @jlehtinen How to Remove means i don't get.i have my proxy at 10.0.0.1 and through this they are able to browse the internet and gateway is 10.0.0.1 – Neeraj Mehta Feb 18 '15 at 15:01
  • You can just block web ports to the outside, our study and implement "transparent proxy" – Dan Feb 18 '15 at 16:38
1

Squid has a wiki on this topic, which they call interception caching.

"How can I make my users' browsers use my cache without configuring the browsers for proxying?"

http://wiki.squid-cache.org/SquidFaq/InterceptionProxy

0

You can use pf-sense it has open source firewall and network management system, with services like squid proxy and manage them using web interface

Using pf-sense you can configure transparent proxy server in which you do not need to configure proxy settings in browser for all users

you can still do it from squid command line by MASQUERADE but you need to configure man in middle for filtering ssl/https sites

you can setup a basic squid using the link setup transparent proxy

-1

you can also use windows server group policy to restrict the user access to the proxy setting. Open Server manager go to tools=>Group Policy Management=>Default Domain Policy Right click on Default Domain Policy and click on Edit=>Policies=>All Setting. now search for "Prevent changing proxy setting" in the middle container.Double click on prevent changing proxy setting and click on "Enable" and then "OK". now don't forget to to run the command in cmd "gpupdate" on both users and server. Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.