I'm trying to convert a fully patched, Windows Server2008 R2 system disk into a VHD by using disk2vhd from Microsoft Sysinternals.

Every time, the conversion fails with error during copy. The error could not be performed due to an I/O error, regardless of whether I sue the vhd or vhdx format, or whetehr I use the Volume Shadow Copy option.

I am a local administrator, running disk2vhd as administrator and have disabled the anti-virus on the server, but it makes no difference.

I see this event in the eventlog around the same time as the error, so I suspect they're related.

Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface. hr = 0x80070005, Access is denied. This is often caused by incorrect security settings in either the writer or requestor process.

Operation: Gathering Writer Data

Context: Writer Class Id: {GUID} Writer Name: System Writer

Writer Instance ID: {GUID}

disk2vhd io error screenshot

What's the problem here, and why can't I get this disk converted?


Its stupid, but running chkdisk first (yes, even when you are getting no error messages or problems anywhere else) before running hd2vhd again has fixed this for us too many times.

  • 3
    I would never call it stupid to check the integrity of a system before converting it to an entirely new platform. This is sound advice, even if it does nothing to fix this particular issue.
    – Spooler
    Sep 30 '16 at 3:28

Well, for one thing, you should probably be using a full-fledged P2V solution for Hyper-V, like Microsoft's Virtual Machine Manager. Alternately, VMware Convertor is something of a standard solution for P2Ving any machine, because it's free, supports most everything you can find to throw at it, and is backed by top virtualization companies out there. (You'd do your P2V, get the virtualized machine into an ovf fromat, and then you'd be able to import the OVF to your Hyper-V host.)

As to the rest:

  1. Just converting the system drive to a virtual disk format is not going to result in a system that's bootable.
  2. You're trying to convert the System Reserved partition (that's what giving you the error - you can't access that, even as an administrator).
  • VMware Converter didn't work, we tried that first. Originally just did C and that had the same issue too.
    – DomBat
    Feb 19 '15 at 9:33
  • @Dom didn't work is a problem description I get from my users which makes me reach for the nearest blunt object. The fact that you unsuccessfully tried Converter is also information that should have been included in the original question. Feb 19 '15 at 9:43
  • possibly, but it just said it was corrupt and no other messages. I prefer Microsoft tools and so this thread is about disk2vhd.
    – DomBat
    Feb 19 '15 at 9:49
  • @DomBat Then add this, in case of next time, to your question that you dont want to get suggests from third party tools.
    – djdomi
    Aug 9 at 10:09

After looking more into the event log entry it suggests that DCOM needs more permission to get to solve the access denied message (adding Network Service).

See here: http://www.terabyteunlimited.com/kb/article.php?id=563

This solved the first issue. Now in the event log it says:

The shadow copies of volume C: were aborted because of an IO failure on volume C:.

and lots of this:

The driver detected a controller error on \Device\Ide\IdePort0

I will research this and post a reply if I get anywhere. The disk is failing, we know this from diagnostics so I hope it is not too far gone!


I have had success using XenServer's free Xen Convert tool when porting a physical windows server to HyperV.

Xen Convert : https://www.citrix.com/go/products/xenserver/xenserver-xenconvert-free.html

Xen Convert Documentation : http://support.citrix.com/servlet/KbServlet/download/28774-102-661315/XenConvertGuide.pdf

Note: I do not yet have a enough "points" to post a comment. So I share a suggestion that would possibly bypass the problem. Xen Convert in general is a more powerful tool then sysinternals disk2vhd that I recommend users try out.


In my case it was a bad sector.

  1. DISK2VHD canceled with an error:

Error during copy. The request could not be performed because of an I/O device error.

  1. Scanned with HDTune (can also be done by other surface scan tools like HDDScan), found a bad sector:

LBA: 1197436

  1. Located the affected file with nfi.exe:

    nfi.exe \Device\Harddisk0\DR0 1197436


  1. Deleted the file.
  2. Restored the file from backup.

Afterwards no reading error on surface scans.

I made successful DISK2VHD image.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.