1

I'm trying to install Laravel, this required me to upgrade to php 5.6.5. This was a success and php is running fine, but im having 2 dependency issues when i try to install other packages that laravel requires such as php mbstring

yum install php-mbstring
...
Packages skipped because of dependency problems:
    php-common-5.3.3-40.el6_6.x86_64 from updates
    php-mbstring-5.3.3-40.el6_6.x86_64 from updates

I thought that this meant php-common was out of date since it was 5.3.3 so i tried updating to the latest version and got this message.

yum install php56w-common

Package php56w-common-5.6.5-1.w6.x86_64 already installed and latest version
Nothing to do

Im still getting the same error. i tried removing the old 5.3.3 version of php-common, but it isnt installed.

My server is running centos 6.6

Update Using the repo from the guide i was using https://iamtrishulpani.wordpress.com/2014/10/21/installing-and-using-laravel-4-2-on-centos-6-5/

I was able to get past this error, but now its telling me that it cant find XZ compression

2

Resolved all of the issues by doing the following. First the issue with XZ seems to be an issue with rpm. The issue with the mbstring might have been a simple command error

wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -ivh epel-release-6-8.noarch.rpm

yum clean all

yum install php56w-mbstring
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.