5

Browser is showing "500 - Internal server error." (I have turned off "Show Friendly Http Messages".

In IIS 8 I have gone to ASP settings and set "Send Errors to Browser = True".

enter image description here

I've got simple ASP pages working fine. I'm porting code from Windows 2003 over to 2012. And having to debug misc issues. The only place I see the error is in the IIS Log after a few minutes. That's way to slow to fix the errors, and it doesn't give much info.

I'm running the browser on the remote server itself. Ideally want to get errors in any browser, not just IE.

Added 02/25/2015 - it seems to work maybe 5% of the time. Most of the time I get 500 Internal Error, but here's one example today were it gave the type of error I wanted in the browser:

enter image description here

6

Below are the Classic ASP Debugging Properites default settings:

enter image description here

All you need to change here is Send Errors To Browser = True

This should give you the real error in a browser on the server.

To see that error in a remote computer click on the Error Pages icon for the site in IIS Manager and click Edit Feature Settings in the Actions pane on the right. Here choose Detailed errors.

enter image description here

then

enter image description here

This is an IIS feature nothing to do with ASP. Ideally on a public server you never want this setting, because it would exposes your error messages to the world. Please remember to switch it back when done with debugging.

  • Thanks, but how is that different from what I posted above? I already had it set to True as I stated. – NealWalters Feb 25 '15 at 19:30
  • Last night, I observed for the first time a message in the browser, but still about 95% of the time, browser just says "500 - Internal Error". Not sure why the 5% of the time it worked like I wanted. – NealWalters Feb 25 '15 at 19:31
  • @NealWalters - You don't mention anything about Error Pages in your post! – Peter Hahndorf Feb 25 '15 at 20:10
  • I can do my testing on server, doesn't need to be remote. But I'll try that too. Updated question, with weird case where it actually worked. – NealWalters Feb 26 '15 at 2:53
  • 1
    Thanks, added two screen shots... At first I was kind of "MIFF"ed that you put the same screen shot I already had in the question. – NealWalters Mar 13 '15 at 1:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.