1

I want to run some binary (which is definitely working on another PC) on virtual Debian PC. Debian 7.5 stable with added testing and unstable repositories. (I'm not an expert in this) This binary uses RPC protocol and it fails with message: "Cannot register service: RPC". Other similar questions suggest that "rpcbind" is needed and so I decided to install it.

Now I run "apt-get install rpcbind" and receive message: The following packages have unmet dependencies: rpcbind : Depends: libtirpc1 but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Next I try to run "apt-get install libtirpc1" and receive message: The following packages have unmet dependencies: libc6 : Breaks: libtirpc1 (< 0.2.3) but 0.2.2-5 is to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

libc6 is needed for my binary and I has installed it before doing operation above.

What could I do next, any advice?

2

Encountered the same issue; downgrading libc6 (to 2.17) did the trick for me.

See https://stackoverflow.com/questions/10863613/how-to-upgrade-glibc-from-version-2-13-to-2-15-on-debian for instructions.

2

Probably your system is trying to get packages from testing/unstable. Try this

sudo apt-get update
sudo apt-get install rpcbind -t stable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.