1

I have had an issue on a few Windows Server 2008 R2 SP1 Standard servers recently where when doing a standard reboot, it will reboot into the WinRE recovery environment. Going to the console of the machine and rebooting the device again will bring it back to the OS with no issue. These are all virtual machines and we have other machines with no issue. The most recent occured after automatic updates ran on a server.

  • Windows update logs don't indicate any failures
  • System logs don't indicate any errors or warnings
  • Checking bcedit /enum I don't see any issues with boot record
  • Checking msconfig->Boot tab no special boot options are selected

I'm at a loss on what else to check. Any ideas? Thanks

0

Apparently this is an intermittent issue with some 2008/2008 R2 environments after a heavy round of updates [insert favourite windows update débâcle anecdote here].

Try this solution on one of your 'less critical' servers, but it is relatively non-aggressive and shouldn't cause any more harm in the event that it doesn't help your particular issue.

let the system boot to windows recovery mode, and open a command prompt -- and type:

sfc /SCANNOW /OFFBOOTDIR=C:\  /OFFWINDIR=C:\Windows

change directory to:

C:\Windows\winsxs\

If pending.xml file exists, delete it...otherwise, reboot the system and select normal boot.

Try another reboot to test, but you should be ok going forward.

Here's some information on the 'sfc' command line utility: https://msdn.microsoft.com/en-us/library/windows/desktop/aa382541%28v=vs.85%29.aspx

Hope this helps, and good luck!

| improve this answer | |
  • Thank you for your reply. Curious if you can point me to any discussion on this being a common issue? I understand the need to run an offline system file check, but not quite sure I understand deleting C:\Windows\winsxs ? Was there a certain file in WinSXS? – floyd Feb 24 '15 at 21:35
  • 1
    I am soooo sorry! That would have destroyed your system :( I left out pending.xml -- that is the file to be deleted, not the entire directory! I updated the initial comment, and I'll dig up some links to discussions and post them shortly. If you would like to play it safe you can always rename it to pending.old or something along those lines. – user205132 Feb 24 '15 at 21:47
  • Thanks. I should also point out that out of the 3 or 4 times this has happened. Only one of those has been during Windows updates. The other times were just standard graceful reboots from the OS. – floyd Feb 24 '15 at 22:05
0

We ran the sfc /scannow but it did not find any issues. We ended up just disabling the automatic Windows Recovery environment by using the following command

reagentc.exe /disable

We did this due to the fact that in every instance of our issue if we rebooted the VM again after it was in WinRE it would boot successfully. So disabling Windows RE seemed to be the best idea, as now it will reboot again if boot issues occur instead of booting into WinRE.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.