1

I set up Postfix under Debian Wheezy with MySQL and virtual users using this tutorial. Thunderbird is recently giving me alerts "You exceeded your mail quota" and saving/moving emails is denied. The user I have set up in the users table in MySQL has a quota set to 0 (Zero). I would think the user has no quota.

I was experiencing the same under Debian Squeeze with a similar setup. In my current Wheezy setup, I actually omitted the quoata patch from the tutorial, to hopefully avoid this issue. I do not see any configuration anywhere that could possibly be overriding the MySQL user quota of 0. I am pretty sure I tried setting the quota to NULL with the same result. Instead of setting a really high quota, I would like to disable the quota alltogether.

BTW, an excerpt from my /etc/postfix/main.cf

mailbox_size_limit = 0

Update, I am using Courier as the mail delivery agent and I have noticed the following file which might be setting the quota?:

/home/vmail/domain.com/username/maildirsize

51200000S

49536186 764

I haven't trusted myself yet in editing or deleting this file.

| improve this question | | | | |
  • You are using postfix with which mail delivery agent? Dovecot? Courier? If dovecot, check "plugin" section on dovecot.conf. – grepmaster Feb 25 '15 at 13:28
2

Actually, there are two components that check your quota:

  • Postfix, the checking process was invoked when you receiving email.
  • Courier, the checking process was invoked when you moving around the email via POP3 and IMAP.

Since you mention Thunderbird who report the quota warning, then likely you haven't disabled quota checking from Courier.

So, how to disable quota in Courier?

At step 7 from your tutorial, you can configure courier via /etc/courier/authmysqlrc. In that file, you define

MYSQL_QUOTA_FIELD quota

You can disable quota by erasing/commenting out that line.

The next step is ensuring that maildirsize file wasn't present in Maildir folder.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.