5

I've got a Windows Server Essentials 2012 R2 domain with a few PCs. One PC is currently connected remotely by VPN. There were some connection issues before, which have since been resolved, but now folder redirection is not working on that client.

It seems that whenever I try to access any network path using the server's DNS name (\\SERVERNAME\Folder Redirection), the folder is marked offline and thus all files which have not been made available offline are inaccessible. However, if I try to access the server using its IP address (\\192.168.1.xxx\Folder Redirection), the folder is online and I can access all files normally.

Any idea why the folder is offline when accessed using the server name but online when using its IP? And is there some way I can "force" the folder to go back online?

I should add that I am able to ping and perform an nslookup successfully for the server (using its name) from the client PC in question.

5

Offline files are a client side-setting, so it's nothing to do with the server. It's all about the client.

First suggestion is to use the fully qualified domain name of the server in your UNC path (\\SERVERNAME.domain.tld\Folder Redirection\) and see if that resolves it.

Second suggestion is to make the file folder available offline via the hostname, by accessing the folder with the host name, as you'd like, and then right clicking it and selecting Always available offline.

Third suggestion is to rebuild your offline files content and or database. (I'm assuming Windows 7 or Vista here.)

From and elevated command line (on the client having this problem) run:

REG ADD "HKLM\System\CurrentControlSet\Services\CSC\Parameters" /v FormatDatabase /t REG_DWORD /d 1 /f

After a reboot, your offline files cache will be wiped out and re-initiliazed, which is often what's required to get it working properly again.

  • The last option (the register modification and reboot) made the trick for me. In my case the Always available offline option was grayed-out. – AxelWass Nov 28 '16 at 15:48
2

Use the FQDN of the server.

\\servername.domain.com\SharedFolder

0

I used option 2 from http://www.syswow64.co.uk/2012/09/windows-7-offline-files-will-not-go.html

  1. Locate and click the following registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache

  2. Click Edit, point to New, and then click DWORD Value.

  3. Type SilentForcedAutoReconnect, and then press ENTER to name the value.

  4. Double-click SilentForcedAutoReconnect.

  5. In the Value data box, type 1, and then click OK.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.