0

I support an IIS 7.5 web server and I've been having a bit of trouble with my app pools. What I am seeing is every so often, the applications using connections to Oracle databases will stop working and throw a "ORA-12154: TNS:could not resolve the connect identifier specified" error. What's maddening is that nothing has changed on the db server, web server, or inside the app. I've tried a TNS Ping to the database and it connects just fine. Apps in the same app pool using SQL Server databases don't seem to have an issue.

IMPORTANT: If I change the app to belong to a different app pool, it starts working again. If I change it back to the original app pool, the error persists.

What could be happening here? I'm at a loss as to why the issue would just pop up out of the blue and only affect certain pools.

Thanks!

  • EDIT: This also happens on applications using SQL Server 2008, so it appears it is not just Oracle to blame. – pburgh Mar 13 '15 at 11:33
1

Try pinging your TNS listener to see if it's up something like this on Linux:

tnsping oracle
...
Used TNSNAMES adapter to resolve the alias
Attempting to contact (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = oracle)))
...
OK (2311770 msec)

If its up but you can't get status from TNS listener like this:

lsnrctl status
TNS-01153: Failed to process string: �9M0

Try forcing the listener to refresh without errors with the following command (again this is linux look for equivalent Windows Server command):

lsnrctl start oracle
TNS-01106: Listener using listener name LISTENER has already been started

It might be related with hardware/and/or/bad oracle tunning/and/or/bad oracle's configuration i have exactly the same error than you except i'm running Apache-Tomcat as a webserver, and right away after i start the webserver my oracle service stops (TNS:listener error, and on my webapp i see the Socket Time Out exception) it's not like you having the chance of actually running your apps for a while before the TNS service stops, i guess that's the OS part.

I'm using a Virtual Machine, VM Fusion with CentOS 6.6 installed, this VM runs just fine on only 1 of 3 different laptops, i can confirm it could be related with RAM memory, how does it looks your server's RAM when that happens ? i incremented this several times and it fixed the issue but then came back ant the only way to get rid of it was to monitor RAM and auto-clean it when reaches maximum then forcing it to run with:

lsnrctl start oracle
  • Welcome to Server Fault! Your answer currently does not seem to provide a workable solution to the question and might be more appropriate as a comment. Please read How do I write a good answer? and consider revising or deleting your current answer. – Paul Mar 10 '15 at 21:31
  • I added info above... I recently found that it's not just Oracle apps that are falling over. Apps using SQL Server also stop working. – pburgh Mar 13 '15 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.