I have a problem with my Watchguard VPN. I've set up the device for SSLVPN (added policies, users, a group etc.) according to this description from the Watchguard docs.

The authentication itself works (no error about wrong login info with proper credentials, and I can see the user in the Firebox System manager), but I can't establish a connection after that. I'm using the Watchguard Mobile VPN with SSL Client, and when I try to login, the log outputs the following:

2015-02-26T09:36:41.230 Requesting client configuration from [myIP]:443

2015-02-26T09:36:54.223 VERSION file is 5.22, client version is 5.22

2015-02-26T09:36:54.742 failed to open shared memory for openvpn command (error: 2), please check the WatchGuard SSLVPN Service

2015-02-26T09:36:54.743 Failed to launched openvpn. retCP=0

Now I have to admit that configuring and managing a this thing is not usually one of my tasks and I haven't done it before, so if any info is still missing, please ask and I will supply whatever is needed. I don't really know what to do, because I'm pretty sure I've done everything according to the manual.

While googling, the only instance of this exact error message was a case where there was a difference between the client and the server version, but I've already checked that (both are version 11.9).

Any help is greatly appreciated.

2 Answers 2


To be REALLY sure, that you have the same client version as on the Firebox, you can download the client directly from the firebox itself by opening https://Firebox_IP/sslvpn.html

In your case I'd try to reinstall the client. It looks much like there went something wrong during the installation or something corrupted it later.

Takes just 5 minutes, so it's worth giving it a try.

  • I'm almost ashamed to admit it, but that seems to have solved the problem. I've been tinkering since roughly the same time yesterday, but it somehow never occured to me to just reinstall the client. Thanks for the help.
    – Christian
    Feb 26, 2015 at 13:11
  • Little addition, since this question seems to still be getting some views: I've recently encountered the same problem again, on a different machine, even after downloading the client from the Firebox. Then I downloaded again, installed again, and it worked. Seems like sometimes something gets borked during the install process.
    – Christian
    May 18, 2016 at 6:47

If some VPN related settings have changed on your firewall, by you or someone else, then reinstall your VPN Client on your local computer. https://YourFireWallIP/sslvpn.html

  • Welcome to Server Fault. Your answer could benefit from more detail. Please edit it to explain in more detail how your solution addresses the OPs question. Jan 7, 2017 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.