1

I am going to migrate my windows server 2003 active directory to a windows server 2008. Nearly everthing works fine now but I can't set the operations masters.

  1. I am logged in as Administrator on my windows server 2008 and right-clicked on my domain in Active Directory Users and Computers
  2. I clicked Operations Masters...
  3. And here I clicked Change...

Now this message box pops-up:

The current Domain Controller is the operations master. To transfer the operations master role to another computer, you must first connect to it.

Problem is, in the Operations Masters window there is not the Windows Server 2008 listed. Its the windows server 2003. What am I doing wrong?

  • Not sure here, but as I recall, the transfer of Operations Master happens as part of the whole migration process. I would think the transfer has already happened and that you are seeing this issue because the only option is to transfer the Operations Master back to the Server 2003. Do you have a particular issue that suggests the Operations Master role is missing on the Server 2008 instance? – MrMajestyk Feb 26 '15 at 10:21
  • Hmm, not really. I just went through a tutorial and he set the operations master. I am nearly new to windows servers. I will reinstall all (Its just a test scenario) to have a clean enviroment and test it again. – Kenneth Feb 26 '15 at 11:06
1

Right click the top of the tree and select "Change Domain Controller" then select the DC that you want to transfer the FSMO roles to and connect to it. Then transfer the FSMO roles.

Note that an automatic graceful transfer like MrMajestyk is describing only occurs during the demotion of a DC. It does not occur during the promotion of a new DC.

0

Just because you are logged into the Windows 2008 machine, it doesn't mean that the focus of your ADUC tool is that server. You can be logged into one DC physically, but be connect to the directory located on another. Make sure to confirm which DC you are connected to before attempting the change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.