3

Today after restarting my data server I was unable to boot because one of the drives wasn't being recognized any more, it is still spinning when I connect it and not making many weird noises except for a very slight (kind of muted) ticking sound for a few seconds. I've tried to connect it using different cables and even another computer but neither worked.

I've setup this server about a year ago and haven't looked at it much since, I'm quite a newbie in the linux world and it all came sudden so I'm a little short on info.

Anyways, the drive in question was part of the RAID1 setup that I made using mdadm which consisted of 2 x 2TB drives, sda and sdb, and I think I may have failed to install grub on sdb or something like that? Because when I now start the server, the only thing it does show is a blinking underscore.

I'm not sure exactly how I configured the partitions back then, but I seem to remember that I made a separate partition for grub, system and data or something. But I'm not sure if I made the grub partition part of the RAID if that is even possible...I guess not? If it's not then I probably am missing grub on the disk that is still alive.

What is my best and safest option now? Because I really don't want to lose my data. I'm getting a new drive (same model) tomorrow but I guess I must be able to boot into the system to rebuild the RAID.

2 Answers 2

2

I'm answering my own question here, as I managed to fix it after a while.

First thing I did was download the 'Recommended download (Floppy, CD & USB in one)' of Super Grub2 Disk from http://www.supergrubdisk.org/. This is a *.iso file, when it is finished downloading, rename it to an *.img.

Next, plug an empty usb drive in your pc, download & install UNetbootin, open it up and choose 'Diskimage', in the dropdown choose 'Floppy' instead of ISO, select the Super Grub2 Disk which you renamed in the previous step, choose your usb drive and hit OK.

When it is finished, you have to boot your server up using that usb. Since I was using a RAID1 the 'Everything' menu in Super Grub2 Disk couldn't find my OS, however the 'Everything+' did.

So I chose my OS and it booted just fine, first thing I did then was make a backup of everything using rsync, just in case.

In order to rebuild my RAID1, I followed this tutorial - https://stavrovski.net/blog/how-to-replace-a-failed-hard-drive-in-raid1-array - as it was pretty much the same situation I was having (except the partitions were already marked as failed and I was unable to remove them, as they were probably already removed? To be sure I applied the answer of the one answer in this thread - Removing a device in "removed" state from Linux software RAID array).

Goodluck to everyone with this same problem ;)

0

You can install bootloader (grub) for example on USB stick and try to boot from it. After that you can try to find your boot partition on raid from grub shell. Also there may be a problem with RAID to boot rootfs from degraded array(You need to run mdadm --run --force array_name from intiramfs to resolve it). Good luck!

1
  • Thanks for the response, I will add my own answer in a minute as I managed to fix it in a kind of similar way, thanks nevertheless :)
    – reveance
    Mar 4, 2015 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.