1

I have a single Windows Server 2012 R2 Active Directory Domain Controller for domain MYDOMAIN. I want to perform remote administration of the Active Directory from a workstation that is not joined to the domain. To achieve this, I'm running the Active Directory Users and Computers tool using runas /netonly user:MYDOMAIN\Adrian.Hofman.

Once in Active Directory Users and Computers, I connect to MYDOMAIN by entering the IP address of the domain controller in the Change Domain Controller... dialog.

This works fine. However, when I do certain operations (for example, creating a new user, or going to the Member Of tab of a users Properties dialog), I get the following error dialog:

The specified domain either does not exist or could not be contacted.

The error dialog appears to be completely benign - after the dialog is dismissed, operation continues normally and successfully.

However, I'm deploying these tools to non-technical users, and I'm concerned the error messages will cause them to lose confidence in the system.

Any pointers on how I can make the error messages go away?

Edit: I've tried the following:

  • I run dcdiag on the domain controller; all tests passed; there didn't appear to be any useful information.
  • I tried using Active Directory Users and Computers from a machine that is joined to the domain, and i don't get the error. I still need to be able to use AD U&C from a non-domain machine, though.
  • Is the non-domain PC pointed to the DC for DNS? – Josh Mar 2 '15 at 23:49
  • No, it's accessing the domain via the IP address of the DC. – Adrian Hofman Mar 3 '15 at 0:20
  • 1
    You could try pointing it at the DC for DNS, there could be things attempting to load via the domain name. – Josh Mar 3 '15 at 15:07
  • +1 old thread but having the exact same issue as @AdrianHofman but connecting to Server 2016, not sure if this was ever resolved? I'm using Server Manager (with machine added to trusted list) to connect to a DC on a different domain over VPN. DNS, and DHCP mmc snap-ins work fine. ADUC though, gives the same issue as described above. Have tried creating a forward lookup zone in the local DNS in case of DNS issue but this doesn't help. Guessing maybe something to do with NetBIOS or other broadcast traffic. – Sapient Saxon Saboo Mar 4 '18 at 23:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.