0

I've added a single entry to a /etc/fstab:

mount //sambashare /media/sambashare

Running mount -a worked just fine, I could access all the files. However, after a reboot, I'm faced with this error:

etho0 is in forwarding mode
Waiting for vmbr1 to get ready (MAXWAIT is 32 seconds).

Recurring reboots do not help. I'm strongly assuming it's related to this fstab entry, as I hadn't done any other changes.

1

The behaviour is as designed.

As you've added a network share to your fstab, networking needs to be up before it can be mounted.

You've created a bridge (vmbr1), which can needs time to set up if STP is enabled, usually 30-40 seconds.

Disabling STP might work, but might be a bad idea considering your setup.

Another solutions would be mounting the share manually in /etc/rc.local (or similar) or using autofs.

| improve this answer | |
2

mount seems like an incorrect value for the first field in your fstab and looks like you simply copied a mount commandline.

(man 5 fstab) ... The first field in /etc/fstab, (fs_spec), describes the block special device or remote filesystem to be mounted. For ordinary mounts it will hold (a link to) a block special device node (as created by mknod(8)) for the device to be mounted, like /dev/cdrom or /dev/sdb7.
For NFS mounts one will have :, e.g., ‘knuth.aeb.nl:/’.

I would expect something like this instead in /etc/fstab:

//sambashare /media/sambashare cifs credentials=/etc/smbcredentials,iocharset=utf8,sec=ntlm,_netdev

The _netdev mount option is strongly recommended, it will delay mounting file-systems that require network access until after the network connection has been established, preventing time-outs.

| improve this answer | |
  • Updating the line to //share /media/share cifs iocharset=utf8,sec=ntlm,_netdev yields the same error. So I might stick with mounting in rc.local, right? – doque Mar 3 '15 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.