0

I'm on a VPS that sometimes OVH restarts. When this happens, apache soesn't start at boot so I need to start it manually everytime. I have already set the command systemctl enable httpd but seems useless. How can I start apache at boot?

  • OVH? What distro? – Halfgaar Mar 3 '15 at 13:00
  • I have CentOS 7 – Gixone Mar 3 '15 at 13:07
  • do you have a passphrase for your private key on a SSL vhost ? – exeral Mar 3 '15 at 15:23
  • Well, for every account on my VPS I have used a passphrase (and admin password have more than 200 character) but I don't use SSL certificate for my site... – Gixone Mar 3 '15 at 16:17
  • I'm not a CentOS grey beard, but is the init script executable? – Daniel Mar 3 '15 at 17:10
0

Try:chkconfig --level 23456 httpd on.

Make sure that you don't have any errors in your apache configurations.

  • It says: Note: Forwarding request to 'systemctl enable httpd.service'. – Gixone Mar 3 '15 at 13:23
  • @Gixone It prints "Note: Forwarding request to 'systemctl enable httpd.service" because using chkconfig is deprecated in your CentOS version. – Adonis Mar 3 '15 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.