4

We have a windows server 2012 box that is hosted remotely. I've been trying to install a security patch and the windows update component appears to be corrupted. The error code i'm getting is 80073712. It will download the updates but fails to install them. Installing manually with msu file doesn't work either. So far the steps i've taken are

  1. run the microsoft fix it tools. It says that it fixed the problems, but then it just fails again.
  2. Rename/delete the SoftwareDistribution folder in the windows folder
  3. Use the Dism command to try and repair it- dism /online /cleanup-image /restorehealth This cause an error 14098. The component store has been corrupted
  4. Used the equivalent command in powershell
  5. I downloaded a server 2012 iso directly from microsoft and mounted it to try and use the /source switch to repair using the iso. Now I haven't really seen a lot of good examples of what the syntax should be for this. This is the command i was trying to use:

DISM /online /cleanup-image /restorehealth /source:wim:D:\sources\install.wim:2

2 is the index number for server standard, which is what we are running. I get the same result, error 14098

Now i also tried this in powershell with this command:

Repair-WindowsImage -Online -RestoreHealth -Source:Wim:D\Sources\install.com:2. I get an error stating the component store is corrupted.

So i'm not sure where to go from this point. I don't even know if i have the syntax right for it to use the install disk as the source file. Any help is appreciated. If there is some other method i haven't thought about maybe. Does anyone know if the CheckSUR tool would work on server 12?

  • Well, before all that, I would have checked the Windows Update log file, honestly. You should find more details about why it's failing, and some might even be useful... or lead you to something useful when Googled. – HopelessN00b Mar 3 '15 at 22:08
  • Try DISM /online /cleanup-image /restorehealth /source:D:\sources\install.wim. The PowerShell command is just a wrapper around dism.exe, no differences. It would be great if you could tell us if you made progress on that issue. – Daniel Mar 13 '15 at 21:06
  • I tried the command you listed. Got the same result. Error 14098. The component store has been corrupted – Brad Swink Mar 20 '15 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.