1

I appreciate this question is quite "out-there" but - has anyone had any success with VOIP over SIP behind a SonicWALL. We are having an issue with one-way audio inbound.

Essentially, the person calling (or called) can hear me (from the phone on the same LAN as the PBX), but we cannot hear them. Packet captures show the RTP traffic coming back to the Sonic and destined for the PBX but it simply cannot be reaching it. My understanding is SonicWALLs use Symmetric NAT and this is the problem as STUN doesn't work with this type of NAT.

Is there any workaround or anyone here with any success?

  • 2
    This is almost always NAT related. The sonic wall has a specific VOIP section. What is your PBX system? If asterisk, shoretel, or cisco I can provide a lot of insight. – David Bogar May 5 '17 at 13:35
0

If it's a sip trunk, you may be able to get away with telling your PBX its IP is your "external" IP, and forwarding tcp/5060 and udp/[rdp range] to it in the sonicwall. The rtp range will be configurable in your pbx. Because you only need one sip endpoint (the pbx - all your phones talk to the outside world via the pbx) this shouldn't require stun or anything "clever".

It sounds like you already have the first bit done if the rtp traffic is really reaching your sonicwall, and not just landing in a blackhole because it is being sent to an rfc 1918 address.

0

The sonicwall should have a "VoIP" tab on the main menu. Is "Enable consistent NAT" selected? That will help. You shouldn't need the SIP transforms, but if you can post a screenshot or that screen we can try a few things.

0

I had the same issue with my voip system, there are two topics you may use, to recover.

  1. have a look on voip nat traversal topic.
  2. forget about NATing the service, and use VPN or tunnel instead.

I have solved my issue with P2P(IP-IP) tunnel with Mikrotik and solve the issue with static route.

-1

Make sure it support sip alg and make sure you are using standard sip port (5060) or change the sip alg to "monitor" the sip port you are using.

The rason for one way audio is because the firewall/router dosent know where to send the incoming udp messages/audio and thats why its getting dropped.

If sip alg is enabled, it will keep track on phone calls and where to send the audio.

  • why is this down voted? – Mr Zach Feb 20 '18 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.