2

I have a HP DL380G5 with ESXi 5.5 and x4 146GB Sata disks in a RAID5 array. I have added one more disk to the server exactly as the other ones and, using SmartStart CD I managed to add the disk to the array. No issues so far.

Next day, using the same CD, I added the unallocated space to the VMWare disk. Waited for another day, restarted the host (server) and when tried to increase the datastore from within vSphere client, I don't see any LUN available for expansion.

In the device view, it is showing the total VMware disk capacity with the space allocated from the new disk (546.8GB).

It's been 2 weeks since this was done and the host has been restarted several times since then but no difference.

Forgot to mention: From "Configuration"-"Storage", I have refreshed and re-scanned all disks several times but unfortunately no luck. Still no LUN available.

I still have the option of SSH it and do so from there, but I would like to rather do it from the vSphere client if possible.

  • Please show screenshots. – ewwhite Mar 4 '15 at 5:32
  • You didn't add a LUN. You extended the existing one. – Rex Mar 4 '15 at 15:10
2

I don't think you're going to find another LUN on the system after extending the array and logical disk, unless you created a new array with the single disk.

You'll likely just see the existing LUN will have some free space, with which you can extend the datastore.

Assuming you're using the c# client, go to the Datastore in question via the Configuration tab for the host, then click on Storage in the Hardware frame. Just above the lowerr pane, click on Properties.... This will bring up a window similar to this one Datastore Properties

In this window, you should be able to click Increase... and extend the VMFS.

  • 1
    Thank you for your answer Greg, I appreciate it. It seems like I was not clear enough in my post and I apologize for that. The problem is actually that. When I click Increase and go to the next windows with the options to do so, there is LUN available, so I cannot increase. I have done this process several times with no issues. I reviewed the process I did a few ties and no problems found. Hence, I'm a little bit lost here. – gasfe78 Mar 6 '15 at 1:57
  • There's a different LUN available in the list when you click Increase? Is it the same LUN as you're currently viewing, or a whole new LUN? – GregL Mar 6 '15 at 13:25
1

Having the same issue here. I found that when you connect your client directly to the host, the LUN will be available in the select LUN screen to expand. Once this is done, the rest of the hosts see the additional space. Seems to be a workaround for now, but haven't had a chance to investigate further.

0
  • You don't have to reboot to do this.
  • Go to Configuration -> Storage -> Rescan All.
  • Rescan to view new storage devices.

enter image description here

  • Now you can choose "Add Storage" and expand the volume.
  • 1
    Thanks for the reply EWWhite. It is my fault as I forgot to mention that this option was already done. No luck unfortunately. – gasfe78 Mar 4 '15 at 4:22
0

Try connecting directly to the ESXi host (using root user), and not vCenter server through the client. I've experienced this issue, and connecting directly to the host resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.