0

i've got a problem with rdiff-backup...

I have three systems:

System-A: Data source, SSH on port 1234

System-B: Backupspace, SSH on port 22

System-C: Executive system which runs rdiff-backup.

my rdiff-call is as follows:

SOURCE_PORT="1234"
SOURCE_USER="user_A"
SOURCE="System-A"
TARGET_PORT="22"
TARGET_USER="user_B"
TARGET="System-B"
#left out the variables for paths
# ...

rdiff-backup --create-full-path --no-hard-links \
--remote-schema=\'ssh -C %s \"sudo rdiff-backup --server\"\' \
'-p ${SOURCE_PORT} ${SOURCE_USER}@${SOURCE}'::${BACKUP_SOURCE_PATH}/${ADDITIONAL_FOLDER}/${BACKUP_NAME} \
'-p ${TARGET_PORT} ${TARGET_USER}@${TARGET}'::${BACKUP_TARGET_PATH}/${ADDITIONAL_FOLDER}/${BACKUP_NAME}

I hoped to get the -p parameter inside the userinfo for placeholder %s, but this won't work. --remote-schema won't work either, because it can set one -p parameter like:

--remote-schema=\'ssh -p 1234 -C %s \"sudo rdiff-backup --server\"\'

Then System-A can be contacted, but connections to System-B fail...

I don't know what to do anymore...

Do someone know, how to tell rdiff-backup to use different ports for the remote data source and the remote backup destination?

0

I don't know, if it's a hack or a feature, but it seems that you can supply a quoted host_info, in which you can provide the port number and thus avoid to use --remote-schema.

For example:

$ rdiff-backup /source/dir "-p 1234 user@host.com"::/remote/dir

HTH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.