0

I've been trying to figure this out for a couple of days now and no luck so I thought I'd ask here.

We have two buildings connected via a line of sight wireless network bridge. We have two routers, one at each building and one, at the new building, is setup to be our gateway and the other, at the old building, is setup in "bridge" mode. Our internet is shared between both buildings via this bridge and all the computers on the network have internet access which means the bridge is functioning.

The problem is the Server, which is at the new building, cannot talk to the computers at the old building and they cannot talk to it. It was working fine Friday of last week. The computers at the new building can talk to the computers at the old building without any trouble.

Note: By talk I mean share and access files and folders.

The question is, why can't the server talk to the computers at the old building when the computers can talk between themselves just fine.

Extra Information:

  • The router at the new building is our DHCP and DNS.
  • Everything is properly pointed to the router at the new building.
  • I tried restarting the computers, server, routers, and network bridge and nothing fixed the issue.
  • Our server is setup as a file server only, nothing fancy.
  • There are about 30+ devices on the network, some wireless and some wired.
  • The server is Windows Server 2008 r2
  • The computers are Windows 7, XP, and a couple 8.1s.
  • I also cannot ping the computers at the old building from the server. However, I can ping any computer at the old building from any other computer at the new building.

If you need more information please let me know. I'd really like to get this problem solved.

Edit 1

  • The server has a static IP address
  • All computers are on the same subnet
  • There is a firewall, but I tried disabling it and nothing changed.

Edit 2

  • When attempting to access the server by Hostname or IP address, i.e. \\servername or \\192.168.1.111, we get a "Network Path Not Found" error.

Edit 3

  • The server has an Avast Firewall installed in addition to the built in windows firewall. The windows firewall is disabled while Avast's is enabled.
  • I have not tried adding the server to the DMZ on the router for security reasons. I may try this later though.
  • There are no static routes configured on either router, I did just configure a static route on the new router for the server to see if it fixes the problem.
  • We do not use group policy, the company was using Windows Home OSes until I was hired and started getting everything switched over to Windows Professional. As such, the server was configured as only a File Server with no Active Directory/Domain anything.
  • I have not tried messing with the HOSTS file but might when I get a chance.
  • We do not use VLANs of any sort, we just don't for no reason in particular.
  • I've checked all the IP Addresses, Subnets, LAN Adapters, Network Teams, Routes.

Tracert Results (Note: IP Addresses listed are not the actual IP Addresses)

  • Server to Old Building: "Server [192.168.1.111] Reports: Destination Host Unreachable."
  • New Building to Server: "1 1 ms <1 ms Server [ab12::cd34::ef56::gh78::ij90]"
  • New Building to Old Building: "1 3 ms 1 ms 1 ms ComputerName [192.168.1.111]"
  • Old Building to Server: Will post when I get a chance to run the test.
  • So what happens exactly when you try to access a share on the server? What messages, if any, do you get? Are you trying to access these shares by name or ip address? – joeqwerty Mar 4 '15 at 16:17
  • I should have mentioned that, when we try to access the server by either Hostname or IP address we get a "Network Path Not Found" error. – tansonnhut Mar 4 '15 at 16:43
0

If I understand well then the new server is the only one that does not behave as it should.

Did you check the IP addresses? All in the same subnet? Did you change/activate a firewall on the new server last Friday?

  • I should've mentioned that the IP address is static and all computers are on the same subnet. The firewall was on prior to last friday and, as I said, everything was working fine then. (Although, I did try disabling it just to make sure and it still did not work) – tansonnhut Mar 4 '15 at 15:41
0

Well - it sounds like you have a classic "WTF-IS-GOING-ON" situation on your hands.

First thing; You mention there is a firewall but that you tried disabling it. I am assuming this is something like a Windows firewall on the server itself?

Second thing; The router at the new building is handling DNS and DHCP. Does it, too, have a firewall? If so, have you tried adding the server to the DMZ for testing purposes only? If not, and it works, do not keep it there for security reasons.

Third thing; Have you checked the routers for static routes that could be "hijacking" / redirecting network traffic unexpectedly?

Fourth thing; Do you have anything going on with group policy where incorrect routes could be pushed out to clients at the old building, such as modifying their HOSTS files? Have you checked the HOSTS file on a computer in the old building to make sure it is not gummed up? Have you tried adding a record in the HOSTS file to see if that will help a computer in the old building communicate with the server? Mostly for testing purposes...

Fifth thing: When you perform a tracert in the old building to the server, what path are the packets following? Is it as it should be? What about in the new building where things work?

Sixth thing: Could the server be VLAN'd away from the old building?

Ultimately since the separation exists between your server and the old building, but the old building is not separated from anything else, I primarily suspect a configuration issue on the server or some config in the network that relates to the traffic heading to the server (such as a route perhaps.) Triple check your subnets, LAN adapters, network teams, routes, VLANs, etc.

Wish I could throw out some more ideas but maybe these tests will give you some things to try.

  • Yes, this is a very "WTF-IS-GOING-ON" situation also, I've answered a majority of your questions is Edit 3. – tansonnhut Mar 5 '15 at 15:17
0

So, I feel kind of stupid now but I'll share the solution with the rest of the class. It turns out that the network team we had setup on the Server was the issue. Our switch isn't load balancing and that apparently caused the connection to the server to be unstable in our new building and unreachable in our old building. So we disabled the network team and everything started working as soon as we rebooted. (I know rebooting most likely didn't fix it because I had rebooted the server about 3-4 times trying different things)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.