1

I am using Proxmox. I tried to run new OpenVZ container and I set my recently registered domain as a hostname in format "three digit number dot ie" (XXX.ie). The problem is, that after starting server, no matter what is written in files /etc/hosts and /etc/hostname the command

hostname -f

alway gives me answer just XXX (without dot ie). This way my domain is not FQDN and I'm having troubles with installation of any software.

I think it is Proxmox bug, because I tried to change hostname to, for example, to test.ie and it worked as it should.

I just querrying myself that maybe I should try set this domain name with quotation marks or any other trick which I don't know.

0

Problem sorted for me. Just changed distro to CentOS 6 and numerical hostname works fine. No clue, why it didn't work with Debian 7

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.