2

I get the following error: ./cataclysm: command not found when trying to run this executable on a Linux server over SSH.

when I run ldd cataclysm, I get:

linux-gate.so.1 =>  (0xf7759000)
liblua5.1.so.0 => /usr/lib/i386-linux-gnu/liblua5.1.so.0 (0xf7716000)
libncursesw.so.5 => /lib/i386-linux-gnu/libncursesw.so.5 (0xf76e6000)
libtinfo.so.5 => /lib/i386-linux-gnu/libtinfo.so.5 (0xf76c6000)
libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xf75d2000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf75a6000)
libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf7588000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf73de000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf73d8000)
/lib/ld-linux.so.2 (0xf775a000)

Is everything ok here?

Also it's a 64-bit server so I also installed ia32-libs, as a I thought this might be the issue, but it's still not working

Edit: solved now, just needed chmod 755 cataclysm

  • 1
    Try "file ./cataclysm" to see what type of file it is. It might be the wrong architecture, and file should show you what it is. – Craig Miskell Mar 5 '15 at 8:15
  • Try to check if your libraries are available at the path shown by ld. See here: superuser.com/questions/248512/… – Andrey Sapegin Mar 5 '15 at 8:22
0

This looks to be a 32-bit binary (you can tell by the /lib/i386-linux-gnu in the ldd output). I think you have the issue figured out after installing 32bit libs and fixing file permissions, but for others who may have the same problem, see this Ubuntu guide on running i386 code on amd64.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.