0

I have a very odd problem that I'm hoping someone might be able to give me even an idea of where to look. I have a new Netgear M4100-D10-POE layer 2 managed switch that we are installing in a remote building. It connects to the rest of out network via a CAT5 cable to a Cisco switch (we have a few and where it connects doesn't appear to matter). Now it works fine and all but when I power off this Netgear switch (or unplug it from the network) I get a bunch of emails from various services that indicate a loss of network connectivity between a pair of other Cisco switches (a Catalyst 3560 and a Catalyst 2960S). These switches are connected to each other via a fiber line.

The odd thing is that the Netgear switch is not directly connected to either of the two switches that suffer a link failure. There could either 1 or 2 other Cisco switches between the two. I also don't see any sort port up/down log messages on either switch. I also know that it is not coincidence because I can recreate the issue anytime by just plugging and unplugging the Netgear switch.

My only guess is it has something to do with BGP, STP or some other switch-to-switch protocol but I don't know how to monitor this.

UPDATE: Here are the config files. First is the Netgear switch:

!Current Configuration:
!
!System Description "M4100-D10-POE ProSafe 10-port FastEthernet L2+ Intelligent Edge PoE Desktop Managed Switch, 10.0.1.28, B1.0.0.9"
!System Software Version "10.0.1.28"
!System Up Time          "2 days 23 hrs 58 mins 15 secs"
!Additional Packages     QOS,IPv6 Management,Routing
!Current SNTP Synchronized Time: Mar  9 19:09:41 2015 UTC
!
network protocol none
network parms 172.16.112.68 255.255.240.0 172.16.112.4
vlan database
vlan 3-10,200
vlan name 3 "VOIP_HD"
vlan name 4 "CAMERA"
vlan name 5 "WIFI_MGMT"
vlan name 6 "WIFI_GUEST"
vlan name 7 "WIFI_DATA"
vlan name 8 "SAN_SATA"
vlan name 9 "SAN_SAS"
vlan name 10 "DMZ"
vlan name 200 "AUTOVOIP"
exit

ip ssh server enable
ip ssh protocol 2
no ip telnet server enable
configure
sntp server "172.16.112.6"
sntp server "0.north-america.pool.ntp.org" 2
sntp server "1.north-america.pool.ntp.org" 3
time-range
ip domain name "caymanport.com"
ip name server 172.16.112.6 172.16.112.23 172.16.112.9
snmptrap "CIPAread" ipaddr 172.16.112.65
voice vlan
no green-mode energy-detect
line console
no transport input telnet
exit

line telnet
exit

line ssh
exit

snmp-server sysname "CDCParts1Switch"
snmp-server location "CDC Taylor Parts Container"
snmp-server contact "IT Manager"
!
no snmp-server community public
no snmp-server community private
auto-voip vlan 200

interface 0/7
vlan participation include 2-3
vlan tagging 2-3
exit

interface 0/8
vlan participation include 2-3
vlan tagging 2-3
exit

interface 0/9
vlan participation include 2-10
vlan tagging 1-10
exit

interface 0/10
vlan participation include 2-10
vlan tagging 1-10
exit

no isdp run
no isdp advertise-v2
exit

Now the Cisco 3560 switch (CDCVOIPSwitch):

Current configuration : 19392 bytes
!
! Last configuration change at 11:31:57 EST Fri Mar 6 2015
! NVRAM config last updated at 15:35:31 EST Tue Mar 3 2015
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
service password-encryption
service sequence-numbers
!
hostname CDCVoipSwitch
!
boot-start-marker
boot-end-marker
!
aaa new-model
!
aaa session-id common
clock timezone EST -5
system mtu routing 1500
ip routing
ip domain-name caymanport.com
ip name-server 172.16.112.6
ip name-server 172.16.112.23
ip name-server 172.16.112.9
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
crypto pki trustpoint HTTPS_SS_CERT_KEYPAIR
 enrollment selfsigned
 serial-number
 revocation-check none
 rsakeypair HTTPS_SS_CERT_KEYPAIR
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip ssh time-out 60
ip ssh authentication-retries 2
!
interface FastEthernet0/1
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/2
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/3
 description vip5312-3752
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/4
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/5
 description vip5330-3757
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/6
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/7
 description vip5330-3756
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/8
 description vip5312-3759
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/9
 description vip5330-3755
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/10
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/11
 description vip5312-3758
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/12
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/13
 description vip5330-3754
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/14
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/15
 description vip5312-3732
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/16
 description camCDCNetRm
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/17
 description vip5312-3751
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/18
 description vip5312-3760
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/19
 description vip5312-3750
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/20
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/21
 description vip5312-3761
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/22
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/23
 description vip5312-3762
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/24
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/25
 description vip5312-3763
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/26
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/27
 description vip5312-3764
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/28
 description AP.Ware.Out.Corner
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport mode trunk
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/29
 description vip5312-3765
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/30
 description AP.Ware.Out.Center
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport mode trunk
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/31
 description vip5312-3766
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/32
 description WLC Port 2 (VL06)
 switchport access vlan 6
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/33
 description WLC Port 3 (VL07)
 switchport access vlan 7
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/34
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/35
 description vip5312-3753
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/36
 description AP.Mech
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport mode trunk
 spanning-tree portfast
!
interface FastEthernet0/37
 description vip5312-3610
 switchport mode access
 switchport voice vlan 2
 switchport port-security aging type inactivity
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 macro description cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/38
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/39
 description WLC Port 4
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/40
 description WLC Port 1 (VL05)
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport mode trunk
 spanning-tree portfast
!
interface FastEthernet0/41
 description AP.Warehouse02
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport mode trunk
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/42
 description AP.Warehouse03
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport mode trunk
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/43
 description AP.Warehouse01
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport mode trunk
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/44
 description AP.CDC.Dwnstairs
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport mode trunk
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/45
 description AP.CDC.Upstairs
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport mode trunk
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/46
 description AP.CDCGuard
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 5
 switchport mode trunk
 switchport voice vlan 2
 spanning-tree portfast
!
interface FastEthernet0/47
 description CDC-3300
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/48
 spanning-tree portfast
!
interface GigabitEthernet0/1
 description HDServerSwitch SM-
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 queue-set 2
 mls qos trust cos
 auto qos voip trust
 macro description cisco-switch
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/2
 description BillingVoipSwitch
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 queue-set 2
 mls qos trust cos
 auto qos voip trust
 macro description cisco-switch
 spanning-tree link-type point-to-point
!
interface GigabitEthernet0/3
 description CDCDelivSwitch MM Fiber
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/4
 description CDCSwitch MM Fiber
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape 10 0 0 0
 queue-set 2
 mls qos trust cos
 auto qos voip trust
 macro description cisco-switch
 spanning-tree link-type point-to-point
!
interface Vlan1
 ip address 172.16.116.2 255.255.240.0
!
interface Vlan2
 ip address 172.16.129.4 255.255.255.0
!
interface Vlan3
 ip address 172.16.130.4 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.112.1
ip http server
ip http secure-server
!
line con 0
line vty 0 4
 length 0
 transport input ssh
line vty 5 15
 transport input ssh
!
ntp clock-period 36029198
ntp server 172.16.112.6 key 0 prefer
ntp server 169.229.70.95 key 0 prefer
end

And next the 2960 switch (HDServerSwitch):

Current configuration : 7496 bytes
!
! Last configuration change at 15:32:04 UTC Mon Apr 7 2014 by admin
! NVRAM config last updated at 15:35:13 UTC Tue Mar 3 2015
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname HDServerSwitch
!
boot-start-marker
boot-end-marker
!
aaa new-model
!
aaa session-id common
clock timezone UTC -5 0
!
ip domain-name caymanport.com
ip name-server 172.16.112.6
ip name-server 172.16.112.23
ip name-server 172.16.112.9
udld aggressive
!
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos
!
crypto pki trustpoint TP-self-signed-1538847872
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1538847872
 revocation-check none
 rsakeypair TP-self-signed-1538847872
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
!
errdisable recovery cause link-flap
errdisable recovery interval 60
!
vlan internal allocation policy ascending
!
ip ssh time-out 60
ip ssh authentication-retries 2
!
macro global description cisco-global
!
interface Port-channel1
 description RumPoint LACP Team
 spanning-tree portfast
!
interface FastEthernet0
 no ip address
!
interface GigabitEthernet0/1
 description VsxHD01-4
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/2
 description VsxHD02-6
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/3
 description VsxHD01-5
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/4
 description VsxHD02-0
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/5
 description VsxHD01-3
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/6
 description VsxHD02-5
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/7
 description VsxHD01-2
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/8
 description VsxHD02-4
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/9
 description RumPoint-1
 spanning-tree portfast
 channel-protocol lacp
!
interface GigabitEthernet0/10
 description VsxHD02-3 (VL10)
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/11
 description RumPoint-2
 spanning-tree portfast
!
interface GigabitEthernet0/12
 description VsxHD02-7 (VL10)
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/13
 spanning-tree portfast
!
interface GigabitEthernet0/14
 description VsxHD02-1
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/15
 spanning-tree portfast
!
interface GigabitEthernet0/16
 description VsxHD02-2
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/17
 spanning-tree portfast
!
interface GigabitEthernet0/18
 description VsxHD02ILO
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet0/19
 spanning-tree portfast
!
interface GigabitEthernet0/20
 spanning-tree portfast
!
interface GigabitEthernet0/21
 spanning-tree portfast
!
interface GigabitEthernet0/22
 spanning-tree portfast
!
interface GigabitEthernet0/23
 spanning-tree portfast
!
interface GigabitEthernet0/24
 description KVMHD
 spanning-tree portfast
!
interface GigabitEthernet0/25
 description CDCVoipSwitch SM-F
 switchport mode trunk
 mls qos trust cos
 macro description cisco-switch
 spanning-tree link-type point-to-point
 spanning-tree guard none
!
interface GigabitEthernet0/26
 description HDSwitch CAT5
 switchport mode trunk
 shutdown
 mls qos trust cos
 macro description cisco-switch
 spanning-tree link-type point-to-point
!
interface Vlan1
 ip address 172.16.112.57 255.255.240.0
!
interface Vlan10
 ip address 172.16.200.57 255.255.255.0
!
ip default-gateway 172.16.112.1
ip http server
ip http secure-server
!
logging esm config
logging history size 500
logging history informational
!
line con 0
line vty 0 4
 transport input ssh
line vty 5 15
 transport input ssh
!
ntp server 172.16.112.6 prefer
ntp server 169.229.70.95 prefer
end

You can see the topology of the network here: http://imgur.com/1CvaqUt

The Netgear switch is connected to CDCSwitch port 30 right now (although it was connected to BillingSwitch at one point). Here is the config for that port:

interface FastEthernet0/30
 description CDCParts1Switch
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree link-type point-to-point
!

It is the link between CDCVOIPSwitch and HDServerSwitch that's going down.

  • Can you share the configs or logs from any of the affected appliances? – Martin Mar 6 '15 at 18:03
  • maybe the two switches are updating each other that a sub branch is offline but the emailing notifier sends the notices out as a loss between the two devices when it isn't. the port may be up but the protocol may be going down during recalculation for maybe stp. Note I'm not an expert. Just throwing out random ideas. – Roger Lin Mar 6 '15 at 18:41
  • BGP is a routing protocol. This sounds like an STP issue. Which switch is the root bridge when the Netgear switch is connected to the network? How long is connectivity lost when the Netgear switch is disconnected from the network? – joeqwerty Mar 6 '15 at 19:11
  • @joeqwerty: I'm not a networking expert so I don't know much about how STP works so how do I find which switch is the root bridge? Connectivity loss is only for like 1 second or less. – Caynadian Mar 6 '15 at 19:53
  • @Martin: I am attempting to get the config from the Netgear but it has issues with the config download for some reason. Probably going to be Monday before I can get it now (leaving for the weekend shortly). – Caynadian Mar 6 '15 at 19:54
1

I'm not an STP expert, but I'll take a crack at this.

The brief loss of connectivity sounds like the expected behavior to me, based on what happens during an STP topology change.

When the STP topology changes (due to a switch port transitioning to or from the blocking or forwarding state, because a switch or uplink is added, removed or fails), some frames may be "blackholed" due to the destination MAC address being available via a path that no longer exists. This occurs until STP converges and the MAC address table expires, which in the case of an STP topology change is reduced from the default of 300 seconds to 15 seconds. Frames will also be flooded through the switching infrastructure as a result of the MAC address tables expiring.

So again, what you're experiencing sounds like the expected behavior.

  • This sounds highly plausible but it's not possible to be certain without configs or topology specifics. – Martin Mar 6 '15 at 21:35
  • I could understand if this Netgear switch was involved in the link that is going down in anyway but it is an outlying switch with only devices connected to it. I don't understand why powering it off or removing it from the network would cause this one link to go down. Certainly, this is the first switch that has caused this. Removal of other Cisco or Linksys switches does not have the same affect. – Caynadian Mar 9 '15 at 19:20
  • I'm upvoting here. This is the correct answer. Your network is a mess. Your spanning tree modes are inconsistent. Plugging in a switch that runs spanning tree in anywhere in your network would be unpredictable. You're not going to get the help you need to fix this problem by chipping away at it in an internet discussion site. You need to hire an expert to fix your topology and get your switches configured consistently. – longneck Mar 9 '15 at 20:01
  • @Caynadian: Check the state of that link on both sides when the problem occurs. Is either side transitioning to the Blocking state? If not, then the link isn't going down and it's probably a blackhole problem. If it is, then your STP topology is seriously messed up. – joeqwerty Mar 9 '15 at 20:13
  • As per everyones comments, I'm going to try and find an expert (not so easy to do on a small island such as ours) to evaluate things. – Caynadian Mar 10 '15 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.