0

I have recently removed the old opscenter and installed new opscenter Opscenter 5.1. When I am trying to add existing cluster to opscenter I keep getting error "Error creating cluster: Timeout while adding cluster. Please check the log for details on the problem."

The opscenter logs

2015-03-06 21:37:56+0000 []  WARN: Unable to find a matching cluster for node with IP        [u'xx.xxx.x.177', u'fe80:0:0:0:8d1:ff:fe01:a40e%2', u'0:0:0:0:0:0:0:1%1', u'127.0.0.1'];
the message was [u'5.1.0', u'/1540438085/conf']. 
This usually indicates that an OpsCenter agent is still running on an old node that was decommissioned or is part of a cluster that OpsCenter is no longer monitoring.

This message keeps repeating

The datastax agent logs

ERROR [Initialization] 2015-03-06 21:41:42,414 Can't connect to Cassandra, retrying
com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query      failed (tried: /127.0.0.1:9042 (com.datastax.driver.core.TransportException: [/127.0.0.1:9042] Cannot connect))
at com.datastax.driver.core.ControlConnection.reconnectInternal(ControlConnection.java:220

Although the agent says its not able to connect to cassandra I am able to connect to cluster using the DevCenter. The nodetool status looks good.

I tried restarting the agents and opscenter without any success

The previous opscenter version was working fine before upgrading to OpsCenter 5.1 Datastax cassandra version being used: 4.0.1

Thanks, Murali

2
  • What version of Cassandra are you using? And is the native_transport enabled in cassandra.yaml? In OpsCenter 5.1 the agent connects locally via the native transport instead of thrift.
    – mbulman
    Mar 17 '15 at 2:52
  • @mbulman. We are using the Cassandra Version: 2.0.9.61. I did not find the exact flag native_transport but found these 2 flags start_native_transport: true native_transport_port: 9042
    – mchapala
    Mar 25 '15 at 17:30
0

I did a fresh opscenter 5.1 install on a new aws instance and opscenter was able to connect to agents fine. However we still saw the error in the agent logs complaining about unable to connect to cassandra. This seems to be the issue with the dse version we have and looks like it got fixed with later versions

We then tried using Dse version 4.0.4 with opscenter 5.1 and were able successfully take backs ups from the opscenter. Since the backups involve communication between agents and cassandra I think the issue is not there in later dse versions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.