0

My problem may be just finger trouble, but after fighting with this for a day on what should have taken 5mins, I am getting fustrated. I am not Cisco Certified at any level, just a fair amount of experience. So I am asking for help before i take a big hammer to this router :)

This equipment is off contract, No TAC suport contract either. My question is below the setup details.

Hardware and physical configuration (these are actual devices, not GNS3): Cisco 7206VXR with NPE-G1 256MB/64MB (more ram and flash has been ordered), No I/O controller (not needed with G-series NPE) only one PA-2FE-TX card installed in slot1, All other slots are "open" (blanking plates installed for cooling reasons) NPE-G1 has 3 gigabit layer 3 interfaces, PA-2FE has 2 fast ethernet layer 3 interfaces.

gi0/1 is connected to another router, this other router has minimal config (only has an IP 4.4.4.4/16 on the connected interface) on it to provide a remote connection to connect to. fa1/0 is connected to a laptop. the laptop ip is statically set to 192.168.1.20/24

software I am trying to use: rommon version 12.2(24)T I am using c7200-kboot-151-4.m2 for the boot loader IOS version c7200-adventerprisek9-mz.152-4.m6

to ensure no other config has lingered, I formatted the flash: before loading the new IOS and cleared all config files from nvram:

with a clean (non-existing) startup-config I enter these commands as shown:

en
conf t
int gi0/1
ip add 2.2.2.2 255.255.0.0
ip nat outside
no shut
exit
int fa1/0
ip add 192.168.1.1 255.255.255.0
ip nat inside
no shut
exit
ip access-list standard 1
permit 192.168.1.0 0.0.0.255 any
exit
ip nat inside source list 1 int gi0/1 overload
end

IOS adds 'ip virtual-reassembly in' to both interfaces automatically. ip cef is enabled by default.

This is all I have ever had to do, works in adventerprisek9-mz.151-4.M4 on c3800 equipment. I have tried setting up a nat pool with only my external IP in it and also tried using a route-map. none have worked so far.

I have also tried using only the gigabit interfaces and still the same results.

I can ping from the 7206 to the laptop and the other router. these each can ping the 7206, but I get no nat translations no matter what I do. I have been using telnet to force a translation.

All of these IOS's require (according to Cisco) 512MB/64MB, I have 256MB/64MB and they load without issues (no warnings) I have 1GB ram and 512MB flash on the way, but since the 124.24 ios works I dont think it is a ram issue.

I have down graded to c7200-kboot-mz.151-4.m2 and c7200-adventerprisek9-mz.151-4.m2 This did not work either. Another downgrade to c7200-kboot-mz.124-24.t3 and c7200-adventerprisek9-mz.124-24.t3 ( just above the lowest IOS usable) just to confirm and this IOS works with my config.

My question is: What am I doing wrong? I have looked at the cisco documentation and at other guides, but I can not make this work with the IOS I need.

I need IOS 15.1 for some other features that are needed in my final setup.

By the way, voting for the hammer requires said voter to put up the replacement cash. ;)

  • Can you please briefly summarize your problem at the top of your post, and maybe provide a more descriptive title? Your post is long and it's hard to find exactly what the problem is without reading every word. – Andrew Schulman Mar 8 '15 at 18:08
0

This problem has been solved, There is a subtle incompatibility with the kboot image and the full IOS image. Simply add a boot bootldr bootflash:ignore statement to your config (must be done in an editor if you dont want the hassle of creating a virtual file) then only have one IOS image in flash, the full image. The router boots and works as expected with a small bonus of reduced boot times.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.