3

I am trying to migrate mailboxes to 365. I am doing a cutover migration. All is going well, except I have about 15 mailboxes that keep failing. I have tracked down the issue I think... on the mailboxes that are failing autodiscover is not returning the EXPR or Outlook Anywhere section.

Examples from Outlook Test Autoconfiguration:

Working User:

<?xml version="1.0" encoding="utf-8"?>
  <Autodiscover ...>
      <Protocol>
        <Type>EXCH</Type>
          ...
      </Protocol>
      <Protocol>
        <Type>EXPR</Type>
          ...
      </Protocol>
      <Protocol>
        <Type>WEB</Type>
          ...
      </Protocol>
   ...
</Autodiscover>

Non Working User:

<?xml version="1.0" encoding="utf-8"?>
   <Autodiscover ...>
      <Protocol>
        <Type>EXCH</Type>
       ...
      </Protocol>
      <Protocol>
        <Type>WEB</Type>
       ...
      </Protocol>
   ...
</Autodiscover>

The non-working users are missing the EXPR section. I have restarted the CAS servers, rebuilt the Autodiscover virtual directories, checked for unusual/unwanted mailbox settings but cant find anything wrong. Out of 200+ mailboxes, 15 are doing this. One is the oldest account in the system, one is the newest account in the system. I really cant see where to go from here.

I have used the Microsoft Remote Connectivity Analyzer, and it sees no problem (I guess because its not missing the EXCH section as I've seen other folks have a problem with.) These users are in different mailbox databases. I just cant see the connection.

Has anyone else seen this issue? Any ideas where to look from here? Any thoughts on what could be preventing that section from happening?

I also used Test-OutlookConnectivity: On most users I get results, on these broken mailboxes I get Fatal Autodiscover failure EXPR = <NULL>

Thanks for viewing, thanks more for suggestions/answers!

2

To the best of my knowledge (meaning I tried lots and lots of things) I'm pretty sure in my case the issue was that the "broken" users had MAPIBlockOutlookRpcHttp set to true. Setting that to false and trying the migration again worked well. I hope this helps folks in the future...

Here a link talking about using that setting to disable Outlook Anywhere... (Of course i needed to enable it, but you get the idea...) Disable Outlook Anywhere

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.