3

When users on OSX 10.10 connect to a remote server (SRV02) fileshare via SMB, they are unable to search the file share... when they do, it just hangs (pinwheel of death). There are several users on OSX that need to be able to search files on the server. Windows 8 users do not seem to be affected as search results appears as expected (albeit slow, at times).

My questions is: is there a service/file indexing service that lives on SRV02 that just indexes files and provides a catalog to the remote computers (Mac's and PC's) to use when they try searching the server?

1

You have to disable access based enumeration on the windows file share and force the mac clients to use SMB1.

Also, don't give full control to CREATOR OWNER: uncheck Full Control, Change Permissions, and Take Ownership. The mac ACLs will screw you in the long run unless you uncheck those permissions.

In order to enforce SMB1 on a mac client:

  1. Create the Global Config:

    $ sudo -s
    $ sudo echo "[default]" >> /etc/nsmb.conf
    $ sudo echo "smb_neg=smb1_only" >> /etc/nsmb.conf
    
  2. Restart the OS X Client

  3. Create a new AD Test user
  4. Log in and check if the issue still persists

This works in 10.9 and 10.10.

0

It seems this product: http://www.acronis.com/en-us/mobility/mac-windows-compatibility/ provides AFP access and allows for clients to search for files and retrieve near-instant results. It also provides faster performance over SMB and comes with a lot of other options, such as file naming policies and enforcement (to ensure Windows client compatibility). The only potential downfall, so far, and to most administrators, will be the cost.

-2

https://discussions.apple.com/message/12067045#12067045

I would recommend you these steps:

Disable IPv6 support:

  • System Preferences > Network > Advanced > TCP/IP Tab > change Configure IPv6 to Link-local only

  • check if this solution helped

Tune kernel parameters via terminal

  • A) Immediately applied - when system is running changes are applied, but after reboot custom parameters are gone
sudo sysctl -w net.inet.tcp.rfc1323=1
sudo sysctl -w net.inet.tcp.delayed_ack=0
sudo sysctl -w net.inet.tcp.sendspace=250000
sudo sysctl -w net.inet.tcp.recvspace=250000
sudo sysctl -w net.inet.tcp.mssdflt=1440
  • check if this solution helped

  • B) Persistent - after you reboot OS X, parameters are applied persistently (until you manually delete /etc/sysctl and reboot again)

sudo bash -c "echo 'net.inet.tcp.rfc1323=1' >> /etc/sysctl.conf"
sudo bash -c "echo 'net.inet.tcp.delayed_ack=0' >> /etc/sysctl.conf"
sudo bash -c "echo 'net.inet.tcp.sendspace=250000' >> /etc/sysctl.conf"
sudo bash -c "echo 'net.inet.tcp.recvspace=250000' >> /etc/sysctl.conf"
sudo bash -c "echo 'net.inet.tcp.mssdflt=1440' >> /etc/sysctl.conf"

  • check if this solution helped

  • C) If doesn't help, try to turn off Windows Scaling rfc1323

  • Keep same values before, but disable rfc

sudo sysctl -w net.inet.tcp.rfc1323=0

  • check if this solution helped

Last try - enable internet sharing:

I hope some of these steps could help you.

MyKE

7
  • Changing system variables doesn't seem to be the correct answer or solution. – Rob W Mar 12 '15 at 15:05
  • Why would you suggest turing on Internet Sharing to resolve an issue with clients hanging when attempting to search on an SMB server?! That's just going to potentially introduce firewall, NAT, and security issues. – morgant Mar 13 '15 at 15:38
  • @morgant It was discussed on Apple support where users had same problem, they tried to enable internet sharing and problem was solved. I agree with you it's not good idea, but it's just for try this method and be sure to know if problem was solved or not, then disable sharing and troubleshoot it on Mac's/Windows Server side. – MyKE Mar 16 '15 at 7:48
  • 1
    This almost seems like the solution: acronis.com/en-us/mobility/mac-windows-compatibility – Rob W Mar 16 '15 at 14:23
  • 1
    @MyKE I would highly suggest including a link to the relevant thread on the Apple Discussion forums for context, otherwise it sounds like a very bad idea. – morgant Mar 16 '15 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.