1

I am using ProxmoxVE. Proxmox is running in Stand Alone Mode. I have a variety of CentOS 7 containers running. When I try to use the "Console" button to login to the machine I am presented with two login prompts, which interfere with each other and prevent me from logging in.

I have tried all three methods of console. NoVNC, VNC, and Spice via remote-viewer.

This is happening on all of my CentOS 7 VMs. I was going to post configs but I am not sure which configs I need to post in order to figure this out.

Example of Issue

I am able to SSH in, and I am able to vzctl enter 1001 just fine.

1

I solved the issue.

I SSH'ed into the container and then from the Proxmox Web Interface started a console and saw that two Gettys were running. I then found out that CentOS 7 starts a getty by default. I disabled that getty and now everything seems to be running fine.

systemctl stop getty\@tty1
systemctl disbale getty\@tty1

after running those, everything is working properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.