I have two servesr here with a Supermicro board, both of which are having the same issue (leading me to believe that it's an error with how I set them up)

Whenever I try to start it up, it gets stuck on either "IPMI Initializing... 91" or "System Initializing.... 91"

I cannot get it to BIOS or anything else, and I'm at a loss as to what I did wrong. Surely it's not a hardware issue, as both servers are having the same problem

After looking it up, the error is "Initialize local bus hard disk controllers". I don't have a drive that has an operating system loaded on it, which is why I am trying to boot from a flash drive. I'm not quite sure what that error means though

Thanks in advance for your help


4 Answers 4


I had a real problem with this on a Supermicro 6017B‐URF hanging at the "System initializing........91". Lacking the tools to complete all the recommendations in supermicro.com/support/faqs/faq.cfm?faq=18922 we fixed the issue by removing the clock battery, attempting to boot without it in place and then re-inserting the battery and rebooting.


Had this problem when the video output was to "UEFI" in BIOS. Resetting the BIOS to defaults (by removing power and the CMOS battery) fixed it by reverting the BIOS video output to "Legacy".


An empty Clock-Battery can cause the same problem.


This can be caused by the video output setting in the BIOS setup. When the OS boots, it usually takes over the video output and switches it to a mode which works. But if the OS doesn't boot, then it can be really hard to try to fix it without seeing the boot error message.

There is a way to see the boot messages without resetting the BIOS though, with the serial console. There are 2 ways I know how to connect to the serial console. One is using ipmitool:

ipmitool -H "$host" -U "$user" -P "$password" -I lanplus sol activate

Where $user and $password are ADMIN on older BMCs.

And the other is first ssh-ing into the BMC and starting the serial console from there:

ssh -l "$user" "$host"
start /system1/sol1

Both give a way to see the POST messages, enter BIOS setup, choose boot device, and interact with the bootloader. Usually after the OS is booted there will be no more output though, because most operating systems don't start a console on the serial port. It's a good idea to set up serial console, but the instructions to do that are out of scope for this answer.

The last time this happened for me seems to be because of a bug though. Because it was enough to boot an OS successfully, and after that the video worked correctly during POST too. It looks like the OS initializing the GPU was enough. I did not try to power cycle the server though, that might have fixed it too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.