5

Background: WDS Server 2012 R2 (runs on a 2012 R2 Hyper-v server), DHCP server runs on a different server in a different physical LAN. Both Lans go into the same Layer3 switch. Currently all my clients that are using PXE boot are on the same LAN as the WDS server. I have set up both install and boot images on the WDS server as well, played with the server settings and the TFTP block size as well. Tried setting udp port range and allowing WINsock to provide them. I have also uninitialized and then initialized the WDS server as well. Further, I Tried adding DHCP option 66,67 and 60 as well, however Adding DCHP options on my DCHP server seems to make matters worse and i get different errors.

Problem: Out of every 10 attempts 3-4 times the network boot is successful and I can install an image from the WDS server. However, many times the client finds the WDS server but fails during the TFTP transfer to get the boot image. I get the following error:

TFTP failed to restart TFTP download failed

I have found plenty of folks on the web with this error but for them it either always fails or it simply works fine. For me its more of a she loves me she loves me not relationship.

Any ideas as to why this works sometimes and many times it does not? My settings are detailed below.

====WDS Server Properties==== PXE Response Tab -PXE Response Policy Respond to all clients (known and unkown) -PXE Response Delay 5 second

AD DS Tab left default settings

Boot Tab PXE Boot Policy -Known Clients: Continue the PXE boot unless user presses the ESC key -Unkown Clients: Continue PXE boot unless user presses ESC Key

Client Tab -Joining a domain: do not join the client to a domain after install -Client Logging: enabled client log error,warning & infromational

DHCP Tab -Nothing checked

TFTP Tab -Max Block Size: 512 -Variable Windows Extension (left unchecked)

Network Tab -UDP Port Policy: set UDP port range 64001 to 65000

Advanced Tab -Domain Controller: WDS should use the following servers dcnameentered & gcnameentered -DHCP Authorization: Do not authorize this WDS server in DHCP

MultiCast Tab -Multicast IP Address: Obtain IP Address from dhcp -Transfer Settings: keep all multicast clients in a session at the same speed

  • is the DHCP server Windows DHCP or ISC DHCPd? – Elliot Labs Mar 15 '15 at 12:56
  • Our DHCP server is a Windows DHCP which runs on our primary DC on Server 2008 R2 – veel84 Mar 15 '15 at 17:43
  • Did you check the DHCP settings in the WDS properties? There are some check boxes for DHCP configurations for on server and remote servers... – Elliot Labs Mar 16 '15 at 17:07
1

In networking when things sometimes work and sometimes do not there's surely a timing issue involved...

I would alternative try

  1. Eliminate the PXE Response Delay 5 second

  2. Set the TFTP Max Block size to 1456

  3. If possible disable Multicast capabilities.

Edit 1:

Also if the failing TFTP transfers immediately abort after the TFTP request it might be a port issue. TFTP transfers require a random UDP port selected in a per-transfer basis (in your case from 64001 to 65000). If the randomly selected port is either blocked by a firewall or used by some other application you transfer will abort.

  • Thank you for the input, I tried this and it did not make a difference. – veel84 Mar 16 '15 at 16:38
  • See the edit at the answer – Pat Mar 16 '15 at 17:11
  • Just saw your edit, and that seems to fit my issue. Where sometimes it works and most times it does not. Windows Firewall is disabled on this server, but i have seen it block things even though its disabled on 2012. For instance, if the firewall is disabled on a 2012 print server you get an error about no more endpoint mappings being available, once you enable the firewall it works. But back to the topic, i don't believe this is a firewall issue because of the few times it does work, I will need to take a look into seeing if the ports are already in use. – veel84 Mar 16 '15 at 17:15
  • 1
    @veel84 sounds like you are disabling the firewall service. don't do that. leave the service running and use the firewall control panel to turn it off. disabling the service causes weird networking issues, as you have seen. – longneck Mar 16 '15 at 17:22
  • 1
    the firewall has to be open to DHCP but also to TFTP ! it is TFTP the one that uses that random port. If the firewall only partially blocks the segment of possible TFTP ports then you can randomly get TFTP transfers that go OK and others that fail. – Pat Mar 16 '15 at 22:19
1

I got the error message before. It is a firewall issue. On my test environment using Hyper-v I turned off firewall on Domain networks and it worked.

  • i have learned that many times, more often than not, its the boot image. Most of the time, in WDS 2012 R2, the boot image does not need additional drivers added to it. I have found that if I add drivers to it some NIC cards even fail to get an IP address during PIX boot. One other big reason for failures is if the boot image is 64 bit. I found a 32 bit boot image with no added drivers to be much less problematic. – veel84 Apr 27 '17 at 18:25
0

I ended up reinstalling WDS and everything worked great after that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.