2

Windows Server 2012 Standard 64-bit.

When I start the WSUS service this error shows up in Event Viewer:

The WSUS content directory is not accessible.
System.Net.WebException: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at Microsoft.UpdateServices.Internal.HealthMonitoring.HmtWebServices.CheckContentDirWebAccess(EventLoggingType type, HealthEventLogger logger)

The server is able to synchronize with Windows Update and finds lots of patches (Critical and Security), but I can't download any updates, as I get this error in Event Viewer:

Content file download failed. Reason: Value does not fall within the expected range. Source File: /c/msdownload/update/software/crup/2015/03/windows6.2-hypervintegrationservices-x86_8c84de57854d4934770a0ed072fb76673e30eb99.cab Destination File: f:WsusContent\99\8C84DE57854D4934770A0ED072FB76673E30EB99.cab.

Screenshot from the server:

enter image description here

1

This appears to be a known issue for WSUS servers that use an authenticated proxy server.

Microsoft has release a hotfix for this issue that you can apply to your server.

According to one person who tried it (linked above), you must perform the following steps to reset the WSUS content repository after installing the hotfix. This is because WSUS "thinks" in the SQL database that all updates have been downloaded when in fact they failed. To do this perform the following steps:

  1. Close any open WSUS consoles.
  2. Go to Administrative Tools – Services and STOP the "Update Services" service.
  3. In Windows Explorer browse to the WSUSContent folder (typically D:\WSUS\WSUSContent or C:\WSUS\WSUSContent)
  4. Delete ALL the files and folders in the WSUSContent folder.
  5. Go to Administrative Tools – Services and START the "Update Services" service.
  6. Open a command prompt and navigate to the folder: C:\Program Files\Update Services\Tools.
  7. Run the command WSUSUtil.exe RESET

One reason for this could be that your DNS is misconfigured. One thing you could do is use a tool like WireShark to see what IP addresses the server is trying to connect to, then look up those IP addresses and make sure they are owned by Microsoft.

Another possibility is that you have some firewall or proxy server that is not letting the traffic through. Make sure that all of the following list of domains are reachable from your server:

  • Thanks for your reply. Unfortunately, there's no proxy in my network. I found this fix by previous research and applied to my server anyway, but the issue has not been not fixed. I also tried reseting WSUS with the command "RESET", and after several hours of SQL processing, the issue persisted. – Vitor Gatti Mar 16 '15 at 14:22
  • @VitorGatti Have you checked the DNS part of my answer? – Moshe Katz Mar 16 '15 at 14:40
  • 1
    I did two procedures: uninstalled and installed WSUS again on my server. I also added all the addresses you provided in my firewall's whitelist. It seems to be downloading now (the WSUSContent folder is finally receiving data). I'll keep monitoring if everything goes well, but thank you for now! – Vitor Gatti Mar 16 '15 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.