0

I have an OpenVPN server which hosts two VPN networks, one is bridged and the other one is routed. See the following draft: enter image description here

The VPNs are working quite well while they are used in isolation.

But if I'm logged in on host3 and I try to get a connection (ping for example) to 192.168.178.1 (host2) this doesn't work. 192.168.178.10 (host1) works.

However beeing on host1, 192.168.178.1 is reachable.

Host1 is a CentosOS 6.5 machine and has ip forwarding enabled:

[root@gw-1 ~]# cat /proc/sys/net/ipv4/ip_forward
1
[root@gw-1 ~]#

Any ideas? Do I need some masquerading is this setup?

  • 1
    How do the routing tables look like? Does host2 know it has to send packets to 10.1.0.0/24 (?) through the tunnel? – Enno Gröper Mar 18 '15 at 7:19
  • What is the OpenVPN configuration? – Tero Kilkanen Mar 18 '15 at 9:08
  • Is there one openvpn server process running on host1? You need to know that in that case forwarding between openvpn clients happens inside the openvpn server process, and not in the kernel. – wurtel Mar 18 '15 at 11:10
0

Ok, the question of @enno-gröper gave me a hint. Of course host2 doesn't know anything about 10.1.0.0/24. So I tried it with masquerading all traffic from 10.1.0.0/24 to 192.168.178.0/24 through tap0 on the OpenVPN server and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.