As the title suggests, I'm trying to lock the directory structure for a folder-hierarchy.

Multiple (W7) users access shared projects on a (QNAP) SMB NAS (ACL & Auth against AD). When new projects are created, a directory structure is copied from a template, and projects are (locked &) archived when done.

A problem that keeps occurring is that (more senior) staff tend to inadvertently drag & drop entire projects into each other - i.e. moving a mouse mid-drag&drop.

I've managed to use icacls prevent deletion of folders on the local disk, but this does not seem to be taking for folders on the NAS, nor does it actually prevent moving one folder into an adjacent one.

Is there a method (or tool) to lock the folder structure, so that folders cannot be moved or deleted by non-admins?


The answer in the Permissions

Create a group and add your users to it. Create the folder structure Put the files in the folders Set the proper write permission on the files so the group can read write and modify Make the folder structure read only, you'll need to do this on every folder Disable inherit permissions

folder options -> Security -> Advanced -> Add Type = Deny Applies to: Subfolders only Show advanced permissions will reveal create folders / append data, delete subfolders and files, change permissions and take ownership

I would do this in a test environment before modifying permissions on your production data.

  • I tried to upload a screen shot but I don't have enough reputation yet. Mar 18 '15 at 1:28
  • Thanks for the tip. I did look at the perms & ACL's, but will emulate your method when I next have an opportunity. Any ideas why the perms/ACL's net on the network resource would not be respected by the client? I can see & set the rights from the client, read them OK from another, but when I want try moving/edit/delete/manipulate data that has been set as locked/RO, it's as if the client does not respect the set right (although it may also be entirely possible the SMB server might not be enforcing it)
    – Jakes
    Mar 19 '15 at 7:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.