2

I have just installed Ubuntu server 12.04 LTS. I am trying to install build-essential package; however, when I try to install it I receive the following error:

Some packages could not be installed. this may mean that you have an impossible situation or it you are using the unstable distribution that some required packages have not yer been created or been moved out of Incoming.
The following information may help to resolve this situation:

The following packages have unmet dependencies:
 build-essential : Depends: gcc (>= 4:4.4.3) but it is not installable
                   Depends: g++ (> 4:4.4.3) but it is not installable
E: Unalbe to correct problems, you have held broken packages.

Before installing I made sure to do an apt-get update. But still doesn't work.

[EDIT]

Based on peterh suggestions:

The content of /etc/apt/sources.list is as follows:

enter code here

# deb cdrom:[Ubuntu-Server 12.04.5 LTS _Precise Pangolin_ - Release amd64 (20140806.1)]/ dists/precise/main/binary-i386/
# deb cdrom:[Ubuntu-Server 12.04.5 LTS _Precise Pangolin_ - Release amd64 (20140806.1)]/ dists/precise/restricted/binary-i386/
# deb cdrom:[Ubuntu-Server 12.04.5 LTS _Precise Pangolin_ - Release amd64 (20140806.1)]/ precise main restricted

#deb cdrom:[Ubuntu-Server 12.04.5 LTS _Precise Pangolin_ - Release amd64 (20140806.1)]/ dists/precise/main/binary-i386/
#deb cdrom:[Ubuntu-Server 12.04.5 LTS _Precise Pangolin_ - Release amd64 (20140806.1)]/ dists/precise/restricted/binary-i386/
#deb cdrom:[Ubuntu-Server 12.04.5 LTS _Precise Pangolin_ - Release amd64 (20140806.1)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://us.archive.ubuntu.com/ubuntu/ precise universe
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

## Uncomment the following two lines to add software from Ubuntu's
## 'extras' repository.
## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

sudo apt-get install gcc produces:

sudo apt-get install gcc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package gcc is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'gcc' has no installation candidate

sudo dpkg -C returns nothing.

  • An apt-cache search gcc can show all of the packages containing the string gcc. Your dpkg -C output shows that at least your package database is okay. What about an apt-get install gcc-4.4? – peterh - Reinstate Monica Jun 3 '15 at 23:38
2
  1. Check your /etc/apt/sources.list, maybe you have multiple distributions?
  2. It says, gcc (at least from version 4.4.3) is not installable, why? You can test this easily by trying to install this with a command apt-get install gcc.
  3. Check if your system has only clean packages with the dpkg -C command. If there are damaged or unconfigured packages, fix them with dpkg --configure -a or by removing/reinstalling them.

Often happens, that you have some packages in multipe versions in your remote repositories. For example, you have a build-essential from testing and stable, but the corresponding gcc is only reachable from stable. The consequence:

  • Trying to install the build-essential, the package manager tries to get your latest package version,
  • but this package version required a newer gcc version as you have in your stable repository.

Similar problems you can easily check with a simple apt-cache show build-essential. If you get multiple packages (with differing versions) you can consider to get a try to an earlier. apt-get install packagename=1.2.3 will install you the package with version 1.2.3 .

I suggest to extend your question with the output of your commands.

| improve this answer | |
1

Found a solution. After more experimenting I found that it was not possible to install other packages using apt as well. Then I noticed that there were hash sum mismatch errors when running apot-get update. In the end I found running the following commands fixed my issue:

apt-get clean
rm -rf /var/lib/apt/lists/*
apt-get clean
apt-get update
apt-get upgrade

After running this I am now able to install build-essential package.

| improve this answer | |
  • 1
    Your second command simply destroyed the package database! After that, you made a complete system reinstall! – peterh - Reinstate Monica Jun 1 '15 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.