0

please can someone help me with this issue. Now when i started sun server - it run on sunfire t100 and os od solaris 5.10, is display this:

checking ufs filesystems /dev/rdsk/c0t0d0s7: BAD SUPERBLOCK AT BLOCK 16: NUMBER OF DIRECTORIES OUT OF RANGE /dev/rdsk/c0t0d0s7: USE AN ALTERNATE SUPERBLOCK TO SUPPLY NEEDED INFORMATION; /dev/rdsk/c0t0d0s7: e.g. fsck [-F ufs] -o b=# [special ...] /dev/rdsk/c0t0d0s7: where # is the alternate super block. SEE fsck_ufs(1M).

/dev/rdsk/c0t0d0s7: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.

THE FOLLOWING FILE SYSTEM(S) HAD AN UNEXPECTED INCONSISTENCY: /dev/rdsk/c0t0d0s7 (/export/home) fsckall failed with exit code 1.

WARNING - Unable to repair one or more filesystems. Run fsck manually (fsck filesystem...).

svc:/system/filesystem/local:default: WARNING: /sbin/mountall -l failed: exit status 32 Reading ZFS config: done. Mar 18 13:59:54 svc.startd[7]: svc:/system/filesystem/local:default: Method "/lib/svc/method/fs-local" failed with exit status 95. Mar 18 13:59:54 svc.startd[7]: system/filesystem/local:default failed fatally: transitioned to maintenance (see 'svcs -xv' for details)

I am connected to server via console. First of all i wanted to increase /var fs because it has only 120mb and shrink /export/home fs. I did it via format utlity but after reboot i was unable to login and disk slice where is /export/home mounted is damaged. But on this fs are no data. Please can somebody help me , i am really desperate, i tried everything that i founf on internet and nothing worked. Please!

0

Did you try and repair using an alternate superblock?

dumpe2fs /dev/rdsk/c0t0d0s7 | grep superblock

to get a list of backup superblocks then use one of the backup superblocks with

fsck -b (backup superblock) /dev/rdsk/c0t0d0s7

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.