2

Yes, I have searched, googled, sworn, googled more but have not quite found the answer I need, .. I have also posted this on a Cisco forum but, as I discovered at stackoverflow, the Stack* forums generally tend to give clear , easy to understand answers, ... so hi,. and here goes:

I know some cisco basics but it seems my knowledge of the Cisco DHCP pools is less than what I thought. Our company has several 3825 (1gb mem) routers which we deploy from time to time for small temporary networks when these are required by our customers Now I have to use one of these routers for a group of 500-600 people on WiFi for a two day event. I took one of my old configs and changed the DHCP pool from 10.10.0.1/24 to 10.10.0.1/22. A assumed that it would just be a matter of changing the pool size and the inverse mask to match. All seemed to work well until the second range (ie: 10.10.1.x or 2.x) was given out. Clients get an IP address but there is no traffic possible to the outside world. I have no idea why. I have posted my config in it's full with just the passwords removed, there are no public IP's in it so no prob there.

Some extra info: My connection is a router provided by the venue, giving me a 192.168.1.1 address on my 0/0 interface.

Although absent in the below config I have tried:

    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0

Neither of these seem to make any difference,... does anyone have an idea whet I am missing or doing wrong?

Thanks for your time!

    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname router1
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret PASSWORD

    no aaa new-model
    !
    resource policy
    !
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.0.1 10.10.0.20
    !
    !
    ip dhcp pool pool1
       import all
       network 10.10.0.0 255.255.252.0
       dns-server 8.8.8.8 8.8.4.4 4.4.2.1 
       default-router 10.10.0.1 
       lease 0 0 10
    !
    !
    !
    voice-card 0
     no dspfarm
    !
    !
    archive
     log config
      hidekeys
    !
    !
    !
    interface GigabitEthernet0/0
     ip address dhcp
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
     media-type rj45
     negotiation auto
     no keepalive
    !
    interface GigabitEthernet0/1
     ip address 10.10.0.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly
     duplex auto
     speed auto
     media-type rj45
     negotiation auto
     no keepalive
    !
    !
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 101 interface GigabitEthernet0/0 overload
    !
    access-list 101 permit ip 10.10.0.0 0.0.3.255 any
    !
    !
    control-plane
    !
    !
    line con 0
     stopbits 1
     line aux 0
     stopbits 1
     line vty 0 4
     password PASSWORD
     login
    !
    scheduler allocate 20000 1000
    !
    end
2
ip address 10.10.0.1 255.255.255.0

Your router will not be able to reply to the data it's being sent, because it itself is restricted to the original /24.

Change this to

ip address 10.10.0.1 255.255.252.0
  • Hi Mark, thanks for your answer, I do not believe that I missed that! How stupid of me. One quick question, do I really need the IP route 0.0.0.0 0.0.0.0 192.168.1.1 ? – Andrew Spring Mar 18 '15 at 21:37
  • If 192.168.1.1 is a router that gets you out to the internet, then yes. I've only seen routing to an interface like you have there when it's a PPP connection, but my experience with different types of interfaces on iOS is limited. – Mark Henderson Mar 18 '15 at 21:42
  • It is indeed a DSL router with 192.168.1.1 as the gateway address, I get allocated the 1.2 address on my 0/0. (not 1.1 as I stated in my initial question). I assumed the ADSL router (1.1) would indeed be the next hop. Thanks again for your time and quick, straightforward answers! – Andrew Spring Mar 18 '15 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.